Dia

Dia-ren eskuliburuaren 0.2 bertsioa duzu hau

Copyright © 2000 Kevin Breit, Henry House, Judith Samson

Baimena ematen da dokumentu hau kopiatu, banatu eta/edo aldatzeko Free Software Foundation-ek argitaratutako GNU Dokumentazio Librearen Lizentziaren 1.1 bertsioan edo berriago batean ezarritako baldintzak betetzen badira; Atal Aldaezinik, Aurreko azaleko testurik eta Atzeko azaleko testurik gabe. GNU Dokumentazio Librearen Lizentziaren kopia Free Software Foundation-en bidez ere lor dezakezu haren web gunea bisitatuz edo hona idatziz: Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Enpresek euren produktu eta zerbitzuak bereizteko erabiltzen dituzten izen asko marka erregistratu moduan hartu behar dira. Izen horiek GNOMEren edozein agiritan agertzen direnean, GNOMEren dokumentazio-proiektuko kideak marka erregistratuak direla konturatu badira, izen horiek osorik maiuskulaz edo hasierako letra maiuskulaz idatzi dituzte.

Edukien aurkibidea

1. Sarrera
1.1. Sarrera
1. Bizkor hasteko
1.1. Zer egin dezakezu?
1.2. Dia abiarazteko
1.3. Bizkor hasteko sarrera
1.4. Oihala sortzea
1.5. Diagrama egitea
1.6. Diagramak gorde eta inprimatzea
1.7. Norentzat da erakargarria Dia?
2. Oihala
2.1. Oihalaren sarrera
2.2. Sareta-marrak
2.3. Erregelak
2.4. Atzeko planoaren kolorea
2.5. Zooma
3. Objektuak
3.1. Objektuen sarrera
3.2. Objektuak erabiltzea
3.2.1. Objektuak gehitzea
3.2.2. Objektuak lekuz aldatzea
3.2.3. Objektuei tamaina aldatzea
3.2.4. Objektuak ezabatzea
3.2.5. Marraren propietateak
3.2.6. Marra-estiloak
3.2.7. Marraren lodiera
3.2.8. Geziak
3.2.9. Marra-koloreak
3.3. Objektuaren propietateak
3.4. Koloreak
4. Oinarrizko objektuak
4.1. Oinarrizko objektuen sarrera
4.1.1. Testua
4.1.2. Laukia
4.1.3. Elipsea
4.1.4. Poligonoa
4.1.5. Beziergonoa
4.1.6. Marra
4.1.7. Arkua
4.1.8. Sigi-saga marra
4.1.9. Koska-marra
4.1.10. Bezier marra
4.1.11. Irudiak
5. Objektu bereziak
5.1. Objektu berezien sarrera
5.2. Objektu berezien kategoriak
6. Objektuak hautatzea
6.1. Hautatzearen sarrera
6.2. Nola hautatu objektuak
6.2.1. Oinarrizko hautapena
6.2.2. Hautapen anizkoitza
6.2.3. Objektuak hautatzeko beste modu batzuk
6.2.4. Konektatutako objektuak hautatzea
6.2.5. Objektu iragankorrak hautatzea
6.2.6. Mota bereko objektuak hautatzea
7. Diagramak kargatu eta gordetzea
7.1. Kargatu eta gordetzeko sarrera
7.2. Fitxategi-motak
7.2.1. Dia diagrama-fitxategi natiboak
7.2.2. Inportatzeko formatuak
7.2.3. Esportatzea: Beste formatu batzuen euskarria
8. Pertsonalizatzea
8.1. Pertsonalizatzea
9. Geruzak kudeatzea
9.1. Geruzen sarrera
9.2. Geruzen oinarrizko kudeaketa
9.2.1. Geruza berria sortzea
9.2.2. Geruzak hautatzea
9.2.3. Geruzak ordenatzea
9.2.4. Geruzak ezabatzea
9.3. Geruzak ikustea
10. Egileak
11. Lizentzia
11.1. Lizentzia

Irudien zerrenda

1.1. Demoa
3.1. Doitzeko puntuak
3.2. Marraren ikonoa
3.3. Marraren propietateak


Atala 1. Sarrera

Edukien aurkibidea

1.1. Sarrera


1.1. Sarrera

Dia diagrama teknikoak egiteko aplikazio bat da. Interfazeak eta eginbideek nolabaiteko zerikusia dute Windows-eko Visio programarekin. Dia-ren eginbideen artean aurkituko dituzu hainbat orritan inprimatzea, formatu askotara esportatzea (EPS, SVG, CGM eta PNG), eta erabiltzaileak XML azalpen gisa sortutako forma pertsonalizatuak erabili hal izatea. Dia oso erabilgarria da UML diagramak, sare-mapak eta fluxu-diagramak marrazteko.

Dokumentu honek Dia-ren 0.96 bertsioa azaltzen du.


Atala 1. Bizkor hasteko

Edukien aurkibidea

1.1. Zer egin dezakezu?
1.2. Dia abiarazteko
1.3. Bizkor hasteko sarrera
1.4. Oihala sortzea
1.5. Diagrama egitea
1.6. Diagramak gorde eta inprimatzea
1.7. Norentzat da erakargarria Dia?


1.1. Zer egin dezakezu?

Dia jende askok erabiltzeko moduko diagrama-aplikazioa da. Lan handirik gabe ikasten da erabiltzen, eta malgutasun handikoa da, bestalde, erabiltzaile adituak eroso senti daitezen tresna komertzialak erabiltzen dituztenean. Behean ikus daiteke Dia-k zer eman dezakeen bost minututan.

Irudia 1.1. Demoa


1.2. Dia abiarazteko

Joan Menu nagusiko Aplikazioak atalera, eta egin klik Dia-ren ikonoan. Edo, idatzi dia komandoa xterm leiho batean.


1.3. Bizkor hasteko sarrera

Oinarrizko diagramak egiteko eskuliburu osoa irakurtzeko gogorik ez duten erabiltzaileentzat.


1.4. Oihala sortzea

Diagrama bakoitza bere oihalean marrazten da. Oihal berria sortzeko, hautatu Fitxategia->Diagrama berria Oihal-leiho berria azalduko da.


1.5. Diagrama egitea

Diagramak objektuz osatzen dira. Kolore. itxura eta tamaina desberdinetako formak dira objektuak. 2 biteko irudiak, irudi koloretsuak, testua, edo beste edozer izan daitezke.

Oihalean objektuak gehitzeko, egin klik tresna-koadroko objektu batean, eta egin klik oihalean. Hautatutako objektua oihalean azalduko da. Izkinetako botoi berdeetan klik egin eta arrastatuz manipulatzen dira nagusiki objektuak.

Objektu baten propietate aurreratuak ikusteko, egin klik tresna-koadroan, ikusi nahi duzun objektuan. Biltegiatuta dagoen bildumako forma zure gustura pertsonalizatzeko aukera izango duzu.

Geruzek irudi anitz sortzen dituzte, irudi bakarra osatuz. Horrela, erabiltzaileak aldiko geruza bat edita dezake, gainerako geruzetan dagoena ukitu gabe.

Gardentasunak objektu zati batzuk garden egiteko aukera ematen du, zati gardenaren atzean dagoen guztia ikusi ahal izateko.

Plugin-en bidez erabiltzaileak objektu-mota berriak gehi ditzake Dia-n, funtzionalitatea areagotzeko.


1.6. Diagramak gorde eta inprimatzea

Diagramak gorde eta inprimatzea dokumentua sortu eta aldatzea bezain erraza da.

Dia-rekin inprimagailuan inprimatu eta gorde egin daiteke. gnome-print instalatuta badaukazu, oso erraz inprimatuko duzu!

Inprimatzeko komandoa Fitxategia menuan dago, oihalean eskuin-klika egitean azalduko zaizu.

Dia-rekin formatu askotara esporta dezakezu web-ean bikain argitaratzeko. Esate baterako:

  • Computer Graphics Metafile (.cgm)

  • Encapsulated Postscript (.eps)

  • Native Dia Format (.dia)

  • Portable Network Graphics (.png)

  • Scalable Vector Graphics (.svg)


1.7. Norentzat da erakargarria Dia?

Industria askotako jende askorentzat izan daiteke erakargarria Dia.

  • Ingeniari elektriko batek zirkuituaren funtzionamendua erakusteko sor dezake Dia-ko diagrama.

  • Informatikako programatzaile batek programaren eskema irudikatzeko erabil dezake fluxu-diagrama.

  • Sare-administratzaileak enpresako sarearen diseinua erakusteko sor dezake diagrama bat.


Atala 2. Oihala

Edukien aurkibidea

2.1. Oihalaren sarrera
2.2. Sareta-marrak
2.3. Erregelak
2.4. Atzeko planoaren kolorea
2.5. Zooma


2.1. Oihalaren sarrera

Oihala da Dia-ren zati nagusia. Erabiltzailearen objektu guztiak pantailan kokatu eta antolatzeko erabiltzen den leihoa da. Diagrama inprimatzen edo gordetzen denean, oihalaren edukia gordetzen da.


2.2. Sareta-marrak

Grafiko-papereko marren antzekoak dira sareta-marrak. Objektuak oihalean lerrokatzen laguntzen diote erabiltzaileari. Sareta-marrak ezkuta daitezke Fitxategia->Hobespenak aukeraren bidez. Sareta-marren fitxan, 'Ikusgai' botoia sakatu behar da, 'Ez' jar dezan.


2.3. Erregelak

Dia-ren oihalaren goialdean eta ezkerrean azaltzen dira erregelak. Oihalaren neurria erakusten dute zentimetrotan.

Erregela bakoitzak gezi bat du. Gezia erregelan zehar mugitzen da, saguak seinalatzen duen puntuaren arabera. Esate baterako, erabiltzaileak sagua gorantz eramaten badu, erregela bertikaleko gezia gorantz joango da, aldaketa adierazteko. Geziak oso erosoak dira objektu bat puntu jakin batean zehazki lerrokatu nahi denerako.

Erregelak ezin dira kendu (sareta-marrak bai, baina erregelak ez).


2.4. Atzeko planoaren kolorea

Aukera honen bidez, oihalaren atzeko planoaren itxura alda dezakezu. Lehenespenez, atzeko planoa zuria izaten da. Kolorea aldatzeko, joan Ikusi+Diagrama-propietateak->Atzeko planoa aukerara, eta egin klik barran. Barran ikusten da atzeko planoaren kolorea. Sareta-marren kolorea automatikoki aldatuko da atzeko planoan kolore beltza ezartzen bada, bestela ez bailirateke ikusiko.


2.5. Zooma

Zoomari esker diagramak hurbilagotik ikus ditzake erabiltzaileak. Horrela zehaztasun handiagoz marraz daiteke.

Zoomaren muga % 400ekoa da. Diagrama handiago ikusteko, egin klik tresna-koadroko lupan, eta egin klik oihalean. Zooma kentzeko, sakatu aldatzeko botoia, eta egin klik berriro oihalean.


Atala 3. Objektuak

Edukien aurkibidea

3.1. Objektuen sarrera
3.2. Objektuak erabiltzea
3.2.1. Objektuak gehitzea
3.2.2. Objektuak lekuz aldatzea
3.2.3. Objektuei tamaina aldatzea
3.2.4. Objektuak ezabatzea
3.2.5. Marraren propietateak
3.2.6. Marra-estiloak
3.2.7. Marraren lodiera
3.2.8. Geziak
3.2.9. Marra-koloreak
3.3. Objektuaren propietateak
3.4. Koloreak


3.1. Objektuen sarrera

Objektuak dira diagrama osatzen dutenak. Aurrez definitutako edo erabiltzaileak definitutako formak dira objektuak.


3.2. Objektuak erabiltzea

3.2.1. Objektuak gehitzea
3.2.2. Objektuak lekuz aldatzea
3.2.3. Objektuei tamaina aldatzea
3.2.4. Objektuak ezabatzea
3.2.5. Marraren propietateak
3.2.6. Marra-estiloak
3.2.7. Marraren lodiera
3.2.8. Geziak
3.2.9. Marra-koloreak


3.2.1. Objektuak gehitzea

Dia-ren oihalean objektuak gehitzeko, egin klik tresna-barrako objektu batean, zuk nahi duzun objektua hautatzeko. Oihalean klik egitean objektua bertan kokatuta geratuko da.

Dia-k bi motatako objektuak eskaintzen ditu:

  • Erabiltzaileak definitutako objektuak - Erabiltzaileak sortzen dituen objektuak txantiloi prefabrikatu batean oinarrituta.

    Adibidez, objektu karratu batean klik egin eta oihalean jarrita, karratu bat sortzen da. Nahi izanez gero, objektuaren neurriak alda daitezke. Ikus Objektuen tamaina aldatzeari buruzko atala.

  • Aurrez definitutako objektuak - Editatu ezin diren diseinuak izaten dira. Tamaina alda dakieke, baina objektua bera ezin da editatu.


3.2.2. Objektuak lekuz aldatzea

Objektu bat oihalean txertatzen denean, ertzak markatzen dituzten koadro berde txiki batzuekin agertzen da.

Irudia 3.1. Doitzeko puntuak

Koadroen barneko area objektuaren area da. Egin klik objektu-arean, eta ez askatu. Mugitu sagua oihalean zehar, objektua oihalaren beste leku batean jartzeko.


3.2.3. Objektuei tamaina aldatzea

Aurreko paragrafoan azaldu da koadro berdeen kontzeptua. Objektuaren tamaina manipulatzeko erabiltzen dira koadro horiek. Tamaina aldatzeko, egin klik botoi berde batean, eta ez askatu. Arrastatu tamaina egokia emateko, eta askatu.

Izkinetako botoi berdeek altuera eta zabalera batera aldatzen dituzte. Goiko eta beheko ertzetan erdian dauden bi botoiek altuera editatzen dute; ezkerreko eta eskuineko ertzetan erdian daudenek, zabalera.

[Iradokizuna] Iradokizuna

Izkinako botoi bat arrastatzen denean proportzioa mantentzeko, eduki sakatuta maiuskulen tekla arrastatzen den bitartean. Objektu bereziei bakarrik aplikatzen zaie hori, ez forma erregularrei.


3.2.4. Objektuak ezabatzea

Objektu bat ezabatzeko, egin klik objektuan, hautatzeko. Koadro berdeak azalduko dira. Sakatu Ktrl+D eta objektua desagertu egingo da.


3.2.5. Marraren propietateak

Dia-ko objektuetako bat marra da. Hau da marra objektuaren ikonoa:

Irudia 3.2. Marraren ikonoa


3.2.6. Marra-estiloak

Marrak erraz edita daitezke geziak eta horrelako elementuak sortzeko. Tresna-koadroaren behealdean 3 botoi daude marrekin. Klik egin eta sakatuta edukita, menu bat azalduko da aldaketaren emaitza ikusteko.

Irudia 3.3. Marraren propietateak

Estilo askotako marrak daude:

  • Betea

  • Marratxoduna

  • Marratxoa-Puntua

  • Marratxoa-Puntua-Puntua

  • Puntukatua


3.2.7. Marraren lodiera

Marren lodiera editatzeko, kolore-hautatzailearen eskuineko bost aukeretako batean klik egin daiteke.


3.2.8. Geziak

Geziak sortzeko, marren tresna erabil daiteke. Tresna-koadroaren behealdeko alboko bi botoietan klik eginda, menu bat azalduko da aukeran dauden gezi-hasiera eta -amaierekin.


3.2.9. Marra-koloreak

Marraren kolorea editatzeko, egin klik bikoitza marran oihalean ipini ondoren. Leiho bat azalduko da. Bigarren lerroa "Marra-kolorea" da eta barra bat dauka hautatutako kolorea erakusteko. Barran klik eginda, marraren kolorea alda daiteke.


3.3. Objektuaren propietateak

Objektu bakoitzak bere propietateak ditu. Oihalean dagoen objektu batean klik bikoitza eginda ikus daitezke. Leiho bat azalduko da hainbat eta hainbat propietate editatzeko aukerarekin, besteak beste:

  • Marra-zabalera

  • Marra-kolorea

.


3.4. Koloreak

Objektu guztiei eman dakieke kolorea hainbat modutan, erabiltzaileak definitutako ezarpenaren arabera.

Kolorearen kontrola tresna-koadroaren behealdetik gertu dago. Bi karratuk egiten dute kontrola. Goian ezkerrean dagoena aurreko planoaren kolorea da. Azpian eskuinean dagoena atzeko planoarena. Koloreak editatzeko, egin klik koadroetako batean, eta hautatu kolorea azaltzen den kolore-leihoan.

[Oharra] Oharra

Kontrol honek oraindik oihalean jarri ez diren objektuen kolorea hautatzeko aukera bakarrik ematen du.

[Iradokizuna] Iradokizuna

Koloreak alderantzikatzeko, egin klik bi koadroen goialdean eskuinean dagoen gezi txikian.

[Iradokizuna] Iradokizuna

Berriz ere kolore lehenetsiak ezartzeko, egin klik kolore-hautatzailearen behealdeko ezkerreko koadro zuri-beltzean.


Atala 4. Oinarrizko objektuak

Edukien aurkibidea

4.1. Oinarrizko objektuen sarrera
4.1.1. Testua
4.1.2. Laukia
4.1.3. Elipsea
4.1.4. Poligonoa
4.1.5. Beziergonoa
4.1.6. Marra
4.1.7. Arkua
4.1.8. Sigi-saga marra
4.1.9. Koska-marra
4.1.10. Bezier marra
4.1.11. Irudiak


4.1. Oinarrizko objektuen sarrera

4.1.1. Testua
4.1.2. Laukia
4.1.3. Elipsea
4.1.4. Poligonoa
4.1.5. Beziergonoa
4.1.6. Marra
4.1.7. Arkua
4.1.8. Sigi-saga marra
4.1.9. Koska-marra
4.1.10. Bezier marra
4.1.11. Irudiak

Lehenengo objektu-mota eta ohikoena oinarrizko objektua da. Oinarrizko objektuak forma geometriko pertsonalizagarriak izaten dira normalean. Dia-k oinarrizko objektu asko eskaintzen ditu.


4.1.1. Testua

Dia-k testua erabiltzeko aukera ematen du objektu-mota propio gisa. Oihalean testua jartzeko, egin klik tresna-koadroko testuaren botoian.

[Oharra] Oharra

Dia-ko testuak Gnome-n erabilgarri dagoen edozein letra-tipo erabil dezake.


4.1.2. Laukia

Dia-ko laukiak erabiltzaileak nahi duen neurrira pertsonaliza daitezke. Hauek dira erabilgarri dauden propietateak:

  • Izkinak biribiltzea - Izkina biribilduak ezartzen ditu ertz zorrotzen ordez.

  • Marraztu atzeko planoa - Erdialdea garbi mantentzen du edo atzeko planoko kolorearekin betetzen du.


4.1.3. Elipsea

Ertz biribilduak dituen forma da elipsea; zirkulua edo obalatua izan daiteke.


4.1.4. Poligonoa

Marra zuzenez osatutako forma itxia da poligonoa. Poligonoen tresnarekin, marra zuzenez osatutako edozein forma marraz daiteke.


4.1.5. Beziergonoa

Poligonoaren antzeko da beziergonoa, erabiltzaileak definitzen baitu forma. Baina, poligonoak ez bezala, forman kurbak sartzen onartzen du.


4.1.6. Marra

Horixe da: marra bat. Ikus marra pertsonalizatzeari buruzko atala.


4.1.7. Arkua

Zirkulu erdiaren antzeko forma bat osatzeko okertu den marra bat da arkua.


4.1.8. Sigi-saga marra

Sigi-saga marra 90 graduko koska zorrotzak dituen marra da. Eskailera-mailen itxura du.


4.1.9. Koska-marra

Sigi-saga marraren antzekoa, baina koskek ez daukate 90 gradukoak izan beharrik. Angeluak pertsonalizatu egin daitezke.


4.1.10. Bezier marra

Kurbak dituen marra da Bezier marra. Bezier marren tresna editatzeko, egin klik puntu berde eta laranjetan, eta arrastatu. Puntu berdeek tamaina pertsonalizatzen dute, eta laranja kolorekoek marra kurbatzeko angeluak.


4.1.11. Irudiak

Dia-ren oihalean irudiak sar daitezke, formekin batera.

Irudi bat gehitzeko, egin klik irudien botoian, eta gehitu oihalean. "Irudi hautsia" izeneko objektu bat azalduko da. Egin klik bikoitza propietateak irekitzeko. Egin klik "Arakatu"n eta hautatu irudia. Egin klik "Ados"en eta irudia eguneratu egingo da.


Atala 5. Objektu bereziak

Edukien aurkibidea

5.1. Objektu berezien sarrera
5.2. Objektu berezien kategoriak


5.1. Objektu berezien sarrera

Aurreko puntuan oinarrizko objektuen azalpena eman da. Atal honetan urrats bat aurrera egiten da, eta objektu berriak sortzen, formak baino landuagoak diren objektu aurrez prestatuak erabiltzen erakusten da.


5.2. Objektu berezien kategoriak

Objektu bereziak kategoriatan banatuta daude. Horrela, zirkuitu bat irudikatzen duen diagrama bat sortzen ari denak zirkuituetako objektuak bakarrik ikusiko ditu. Dia-k aurrez definitutako kategoria asko ematen ditu.

Zirkuitua

Zirkuitu elektrikoen diagramak egin nahi dituztenentzako multzoa.

Eskailera

Nik dakidana baino gehiago da hau

ER

Entitate-erlazioen diagramen editorea

FS

Funtzio-egituren diagramen editorea

Fluxu-diagrama

Fluxu-diagrametan normalean erabiltzen diren formak biltzen dituen multzoa. Asko erabiltzen dira fluxu-diagramak informatikan, marketinean, ekonomian eta plangintza behar duten beste eragiketa erdi-lineal askotan.

GRAFCET

Trantsizioarekin asoziatutako urratsa, ekintza, trantsizioa eta baldintza marrazten dituen diagrama.

SADT

Oso galdera ona!

UML

Ikus goikoa

Kronograma

Diseinu kronografikoan erabiltzen diren objektuak eskaintzen ditu. Ohikoak dira plangintzetan.

Sarea

Sare-administratzaileek erabiltzen dute sarea diseinatzeko.

Sybase

Sybase ordenagailu-sareko fluxua adierazten duten diagramak diseinatzeko.

Elektrikoa

Elektrizitate-fluxua erakusteko izango da, nik uste.

Pneumatikoa/Hidraulikoa

Hidraulikaz baliatzen diren gailuen diagramak egiteko.


Atala 6. Objektuak hautatzea

Edukien aurkibidea

6.1. Hautatzearen sarrera
6.2. Nola hautatu objektuak
6.2.1. Oinarrizko hautapena
6.2.2. Hautapen anizkoitza
6.2.3. Objektuak hautatzeko beste modu batzuk
6.2.4. Konektatutako objektuak hautatzea
6.2.5. Objektu iragankorrak hautatzea
6.2.6. Mota bereko objektuak hautatzea


6.1. Hautatzearen sarrera

Objektuak hautatzea izango da seguru asko Dia-n gehien egiten dena. Objektu berri bat sortzen duzunetik hasi eta diagrama erabat amaituta dagoela pentsatzen duzun arte, etengabe ariko zara objektuak hautatzen, behar bezala ezartzeko.

Objektu bat hautatzen duzunean, objektu horri ematen diozu fokua editatzeko. Hautatuta ez dagoen objekturik ezin da editatu.

Objektuak hautatzeko modu asko daude, eta eragiketa asko egin daitezke hautatuta dauden objektuekin.

Diagraman zehar arrastatzeko bakarrik hauta dezakezu objektu bat, edo beste batzuekin elkartu eta errazago manipulatzeko, edo beste batzuekin konektatzeko, edo besterik gabe diagramatik kentzeko.


6.2. Nola hautatu objektuak

6.2.1. Oinarrizko hautapena
6.2.2. Hautapen anizkoitza
6.2.3. Objektuak hautatzeko beste modu batzuk
6.2.4. Konektatutako objektuak hautatzea
6.2.5. Objektu iragankorrak hautatzea
6.2.6. Mota bereko objektuak hautatzea


6.2.1. Oinarrizko hautapena

Objektu bat hautatzeko modu oinarrizkoena bertan klik egitea da.

Objektua hautatuta dagoenean, inguruan puntu berde batzuk dituela azalduko da.

Puntu berdeak agertzen direnean, has zaitezke objektua manipulatzen. Amaitzen duzunean, diagramako leku huts batean klik egin dezakezu objektua desautatzeko. Puntu berdeak desagertu egingo dira, eta beste objektu bat hautatzeko moduan egongo zara.


6.2.2. Hautapen anizkoitza

Aldi berean objektu bat baino gehiago hautatzeko modurik errazena, diagramako leku huts batean ezkerreko sagu-botoiaz klik egin eta, askatu gabe, sagua arrastatzea da. Horrela laukizuzen bat marraztuko da Oihalean. Area horretan dauden objektu guztiak hautatuta geratuko dira sagu-botoia askatzean.

Beste modu bat, Maius tekla sakatuta edukiz objektuetan banan-banan klik egitea da.

Hautapena egindakoan, hautatako objektu guztiek puntu berdeak izango dituzte inguruan (goian azaldu den bezala).

Hautapen anizkoitza praktikoa da eragiketa bera egin nahi denean hainbat objekturekin, eta banan-banan egiten denborarik galdu nahi ez denean.

Hautatuta daudenean, talde gisa funtzionatzen dute objektuek. Horrek esan nahi du, objektuetako bat arrastatzen baduzu, talde osoa arrastatuko duzula. Gauza bera gertatuko da horietako bat ezabatzen saiatzen bazara: talde osoa ezabatuko duzu diagramatik.

Diagramako leku huts batean klik egiten baduzu, edo beste geruza batera aldatzen bazara, hautapena galduko duzu. Bestalde, hautapenean objektu gehiago sartu nahi badituzu, sakatu Maius tekla eta joan klik eginez gehitu nahi dituzun objektuetan.

[Oharra] Oharra

Diagramako objektu batzuk hautatuta dituzunean, horietako baten tamaina alda dezakezu gainerakoen tamaina edo posizioa aldatu gabe. Nola egiten den ikusteko, irakurri Objektuei tamaina aldatzeari buruzko atala.


6.2.3. Objektuak hautatzeko beste modu batzuk

Ondoren azaltzen dira objektuak hautatzeko beste modu batzuk. Denak Laster-menu nagusian daude, Hautatu menuan:

Objektu guztiak hautatzeko

Hautatu Denak aukera, uneko geruzan dauden objektu guztiak hautatuko dira, eskuz egingo zenukeen moduan.

Aukera hau erosoa da diagramak objektu asko dituenerako, ez baituzu denborarik galdu behar denak banan-banan hautatzen.

Objektu guztiak desautatzeko

Hautatu Bat ere ez aukera, eta hautatuta zeuden objektu guztiak desautatuta geratuko dira. Gauza bera lortuko duzu diagramako leku huts batean klik eginda ere.

Objektuak desautatu ondoren, ezingo duzu eragiketarik egin objektu horiekin. Eragiketak egiteko, berriro hautatu beharko dituzu

[Iradokizuna] Iradokizuna

Zenbaitetan hautapen iraunkorrak egitea komeniko zaizu. Horretarako, talde arbitrario bat sor dezakezu hautatutako objektuekin, edo denak batera ebaki eta geruza berri batean itsatsi.

Hautapena alderantzikatzeko

Demagun hamar elementu dituzula diagraman eta zortzi hautatu nahi dituzula. Zortzi horiek hautatzeko, Hautatu menuko Alderantzikatu aukera erabil dezakezu.

Hauta itzazu eskuz hautapenetik kanpo utzi nahi dituzun bi elementuak, aukeratu Alderantzikatu aukera, eta beste zortziak hautatuta geratuko dira.

[Iradokizuna] Iradokizuna

Gauza bera egiteko beste modu bat, elementu Denak hautatu (goian azaldu da nola egin), Maius tekla sakatu, eta kanpoan utzi nahi diren biak banaka desautatzea da.

[Oharra] Oharra

Uneko geruzan dauden objektuak bakarrik hauta daitezke. Objektu bat ezin baduzu hautatu, beste geruza batean egongo da seguru asko. Geruza batetik bestera nola joan zaitezkeen edo geruzak nola manipulatzen diren ikusteko, irakurri Geruzak kudeatzeari buruzko atala.


6.2.4. Konektatutako objektuak hautatzea

Dia-k eskaintzen duen baliabide benetan ahaltsu eta praktiko bat objektuen arteko konexioak maneiatzeko aukera da.

Gauza askotarako erabil daitezke Dia-ko konexioak. Lehenik, bi objekturen arteko zuzeneko erlazioa espresuki zehazteko.

Bigarren, ezarritako arauen araberako portaera duten objektuak errazago kudeatzeko eta klik gutxi batzuekin atzitzeko.

Objektu jakin batekin konektatutako objektuak hautatzea oso erraza da: hautatu objektu jakin hori, egin klik eskuineko botoiaz Oihalean Laster-menu nagusia bistaratzeko, eta egin klik Hautatu->Konektatuak botoian.

Objektu horrek konektatutakorik ez badu, ez du ezer egingo. Bestela, konektatutako objektu guztiak magikoki hautatuko dira eta aldi baterako hautatutako objektu-talde bat osatuko dute.

[Oharra] Oharra

Gauza bera berriro egiten baduzu, talde berriari konektatutako objektu guztiak hautapenean gehituko dira.

Eragiketa berriro egin dezakezu, harik eta elkarrekin konektatutako objektu guztiak hautatu arte.


6.2.5. Objektu iragankorrak hautatzea

Goian erakutsitako teknika baliagarria da konektatutako objektu gutxi hautatu nahi direnerako.

Baina batzuetan elkarrekin konektatutako objektu asko batera hautatu nahi izango dituzu. Eta objektuak urratsez urrats hautatze hori ez da praktikoa.

Horregatik eskaintzen du Dia-k urrats horiek denak batera egiteko aukera.

Horretarako, hautatu erroko objektua, egin klik eskuin-botoiaz Oihalean Laster-menu nagusia ager dadin, eta sakatu Hautatu->Iragankorra botoia, Konektatuak aukeratu beharrean.

Eta hori da dena; hautatu duzun erroko objektuarekin konektatutako objektu guztiak hautatuta egongo dira orain, manipulatzeko prest, nahi dituzun eragiketa guztiak egin ditzazun.


6.2.6. Mota bereko objektuak hautatzea

Dia-k truku batzuk eskaintzen ditu mota bereko objektuak hautatu ahal izateko.

Edozein arrazoirengatik mota bereko objektuak hautatu behar badituzu (Laukizuzen guztiak, Marrak, Forma pertsonalizatu batekoak) aski duzu mota horretako objektu bat hautatzea, eta gero Laster-menu nagusia ireki eta Hautatu->Mota berekoak botoia sakatzea.

Automatikoki hautatuko dira hasieran hautatu duzun objektuaren mota bereko objektu guztiak. Uneko geruzan dauden objektuak bakarrik hautatuko dira.


Atala 7. Diagramak kargatu eta gordetzea

Edukien aurkibidea

7.1. Kargatu eta gordetzeko sarrera
7.2. Fitxategi-motak
7.2.1. Dia diagrama-fitxategi natiboak
7.2.2. Inportatzeko formatuak
7.2.3. Esportatzea: Beste formatu batzuen euskarria


7.1. Kargatu eta gordetzeko sarrera

Mahaigaineko aplikazio gehienen eredu berari jarraitzen dio Dia-k diagramak gordetzeko: oihalak espresuki gorde behar dira. Fitxategi bat gordetzeko, aukeratu Laster-menu nagusiko Fitxategia->Gorde aukera. Gordetzeko elkarrizketa-koadro estandarra agertuko da. Oihala Dia-ren XML formatuan gordeko da. Fitxategi-luzapena ez da automatikoki gehitzen, eta, beraz, komeni da '.dia' espresuki gehitzea idazten duzun izenari.

Lehenago Dia-n gordetako oihal bat edo beste aplikazio batekin sortutako bat kargatzeko, hautatu Menu-barra nagusiko Fitxategia->Ireki... aukera. Irekitzeko elkarrizketa-koadroa azalduko da; hautatu fitxategia, eta aukeratu Ireki. Irekitzeko elkarrizketa-koadroa estandarra da, Zehaztu fitxategi-mota izeneko menua izan ezik. Aukeratu ireki nahi duzun fitxategiaren formatua (Dia XML edo Drawing Interchange) Dia-k berak ez badu formatu egokia asmatu.

FItxategiak kargatzeko beste metodo bat Dia komando-lerrotik abiaraztea da, ireki nahi den fitxategiaren izena argumentu gisa jarrita.


7.2. Fitxategi-motak

7.2.1. Dia diagrama-fitxategi natiboak
7.2.2. Inportatzeko formatuak
7.2.3. Esportatzea: Beste formatu batzuen euskarria

Fitxategi-motei buruzko azalpen batzuk ematea komeni da. Ohartuko zinen edozein fitxategi-formatu ezin dela berriro kargatu Dia-n gorde ondoren, eta onartzen diren fitxategi-formatu gehienek informazioa galtzen dutela neurri batean.


7.2.1. Dia diagrama-fitxategi natiboak

Galerarik ez duela izango bermatzen duen formatu bakarra Dia XML da. Zorionez, zaila da nahi gabe galeradun formatu batean gordetzea, Fitxategia->Gorde aukerak Dia XML formatuko fitxategian gordetzen duelako beti.

Dia XML formatuko fitxategiak automatikoki konprimitzen dira gzip-ekin, diskoan leku gutxiago hartzeko. Hori ia-ia beharrezkoa da, informazio erredundante asko biltegiratzen delako diagrametan, eta konprimitu gabe diagramarik sinpleenak ere oso handiak izaten direlako. Dia XML fitxategiak dagoeneko konprimituta egoten direnez, ez itzazu konprimitu eskuz, alferrik izango da.


7.2.2. Inportatzeko formatuak

Dia-k fitxategi-mota hauek inporta ditzake:

  • SVG

  • DXF

  • XFig


7.2.3. Esportatzea: Beste formatu batzuen euskarria

Dia-k beste formatu askotara esporta dezake, esate baterako:

  • Computer Graphics Metafile

  • Dia forma-fitxategia

  • DXF

  • HPGL

  • EPS

  • PNG

  • SVG

  • TeX Metapost makroak

  • TeX PSTricks makroak

  • WPG

  • XFig

  • XSLT

Dia-k ezin du formatu horietako gehienetako fitxategirik kargatu. Formatu horiek ongi etortzen dira diagrama bat beste aplikazio batean erabili behar duzunerako edo Dia onartzen ez duen sistema eragile bat duen bati pasatu behar diozunerako.

Formatu horietako bateko fitxategia sortzeko, hautatu Fitxategia->Esportatu... Laster-menu nagusian. Gordetzeko elkarrizketa-koadroaren antzeko bat azalduko da; aukeratu fitxategiaren izena eta formatua. Automatikoki gehituko da fitxategi-luzapen egokia.


Atala 8. Pertsonalizatzea

Edukien aurkibidea

8.1. Pertsonalizatzea


8.1. Pertsonalizatzea

Dia hainbat modutan alda daiteke, erabiltzailearen premia eta gustuetara egokitzeko.

Portaera aldatzeko, hautatu Fitxategia->Hobespenak... Menu-barra nagusian. Hobespenen elkarrizketa-koadroa irekiko da ( )

Hauek diraErabiltzaile-interfazea fitxan alda daitezkeen propietateak:

  • Berrezarri tresnak sortu ondoren botoia hautatuta badago,

  • Desegiteko mailak -- desegiteko tresnak zenbat urrats desegin ahal izango dituen ezartzen du. Zenbat eta zenbaki handiagoa ezarri, orduan eta pauso gehiago eman ahal izango dira atzerantz, baina memoria gehiago beharko du.

  • Zabalerak diagrama berriaren zabalera kontrolatzen du, pixeletan.

  • Altuerak diagrama berriaren altuera kontrolatzen du, pixeletan.

  • Handitu aukerak diagrama berrien zoom-multiplo lehenetsia ezartzen du.

  • Atxiki -- objektuak programak sortutako saretak erakar ditzan. Horrela erabiltzaileak errazago lerrokatuko ditu objektuak, automatikoki erakarriak izango baitira sareta-marrara.

  • X tamaina -- sareta-marra horizontalen arteko tartea ezartzeko aukera ematen du.

  • Y tamaina -- sareta-marra bertikalen arteko tartea ezartzeko aukera ematen du.

  • Kolorea -- sareta-marrak bistaratzeko kolorea ezartzen du.

Nahi dituzun aldaketa guztiak egin ondoren, egin klik Ados botoian aldaketak aplikatu eta Hobespenen elkarrizketa-koadroa ixteko. Aldaketak bertan behera utzi eta aurreko balioetara itzultzeko, egin klik Itxi botoian. Aldaketek izango duten eragina ikusteko, 'Aplikatu' botoia erabil dezakezu.


Atala 9. Geruzak kudeatzea

Edukien aurkibidea

9.1. Geruzen sarrera
9.2. Geruzen oinarrizko kudeaketa
9.2.1. Geruza berria sortzea
9.2.2. Geruzak hautatzea
9.2.3. Geruzak ordenatzea
9.2.4. Geruzak ezabatzea
9.3. Geruzak ikustea


9.1. Geruzen sarrera

Dia-n, geruzak kudeatzeko Geruzen elkarrizketa-koadroa erabiltzen da, eta bertatik egiten dira geruzei buruzko eragiketa guztiak.

Oro har, diagramaren barnean elkarrekin erlazionatuta dauden objektuak elkartzeko erabiltzen dira geruzak. Diagramaren zatiak isolatzeko erabil daitezke geruzak: zati batzuk bistaratu eta beste batzuk ezkutatzeko, baita diagrama esportatzen edo inprimatzen denean ere.

Geruzaren barnean egin nahi duzun edozein eragiketa, Laster-menu nagusiaren bidez egin dezakezu, eta hortik landu ditzakezu objektuak normalean egiten duzun moduan.

[Oharra] Oharra

Uneko geruzan dauden objektuak bakarrik hauta daitezke. Objekturen bat hautatu ezin baduzu, begiratu uneko geruzan dagoen ala ez.

Lehenespenez, diagrama berri bakoitzean geruza lehenetsi bat egoten da: hori da Atzeko planoko geruza. Nahi baduzu, geruza horren izena eta ezarpenak alda ditzakezu, zure premietara egokitzeko, beste edozein geruzarekin egingo zenukeen bezala.

Nahi adina geruza sor ditzakezu; lehendik dauden geruza guztien gainean kokatuko du geruza berria Dia-k. Geruzak bata bestearen gainean pilan jarritako paper gardenak direla pentsa liteke. Pilan daukaten ordena alda dezakezu; geruza bakoitza erakutsi edo ezkutatu nahi duzun erabaki dezakezu; geruza bakoitzean nahi adina objektu marraz ditzakezu; eta abar.

Hori dena Geruzen elkarrizketa-koadroan kudeatzen da.


9.2. Geruzen oinarrizko kudeaketa

9.2.1. Geruza berria sortzea
9.2.2. Geruzak hautatzea
9.2.3. Geruzak ordenatzea
9.2.4. Geruzak ezabatzea


9.2.1. Geruza berria sortzea

Geruza berria sortzeko, egin klik elkarrizketa-koadroaren behealdeko Geruza berria botoian. Geruzen elkarrizketa-koadroa aplikazioa osoarena denez, eta ez diagrama bakoitzarena, geruza berria zein diagramatakoa den zehaztu beharko duzu. Horretarako, hautatu diagrama Geruzen elkarrizketa-koadroaren goialdean, eta gehitu geruza berria hautatutako diagraman.

Geruza sortu berria pilaren goialdean kokatuko da eta hautatutako diagramako uneko geruza izango da.

Orduan nahi dituzun objektu berriak editatu ahal izango dituzu, beste geruza edo diagrama batetik kopiatu eta itsatsi, geruza bakarreko diagrama batean egingo zenukeen moduan.


9.2.2. Geruzak hautatzea

Geruzen elkarrizketa-koadroan hautatzen denean aktibatzen da geruza. Geruza bat hautatzeko, egin klik geruzaren izenean elkarrizketa-koadroan; nabarmenduta geratuko da. Hortik aurrera, egiten dituzun aldaketa guztiek geruza horretan eta horretan bakarrik izango dute eragina.

[Oharra] Oharra

Aldiko geruza bakarra hauta daiteke. Horrela, nahi duzuna egin ahal izango duzu geruza horretan, diagramako gainerako geruzak ukitu gabe.


9.2.3. Geruzak ordenatzea

Geruzen elkarrizketa-koadroaren behealdean, Geruza berria botoiaren ondoan, beste bi botoi daude, sortzen dituzun geruzek pilan duten ordena egokitzeko.

Geruzen hierarkian geruzak gorago edo beherago eramateko erabiltzen dira botoi horiek. Gora gezia duen botoiak geruza goratu egiten du, eta besteak, berriz, hierarkian beheratu egiten du.

Geruzak ordenatzea ongi etortzen da objektu baten zati batzuk beste batekin batera ezkutatu nahi direnean.


9.2.4. Geruzak ezabatzea

Geruza bat gehiago behar ez baduzu, bertako objektu guztiak ezaba ditzakezu Ezabatu geruza botoian klik eginda. Normala denez, unean hautatuta dagoen geruzan bakarrik izango du eragina horrek.

Tarteka egitea komeni da diagrama garbi eta txukun edukitzeko, Dia formatu natibotik kanpora esportatu nahi duzunerako batez ere.

Kontuan izan diagramek geruza bat behintzat eduki behar dutela, diagramak geruzen bidez eraikitzen direlako, eta, beraz, geruzarik gabeko diagramak hondatutzat joko direla eta ezingo direla gorde edo esportatu Dia formatu natibotik.


9.3. Geruzak ikustea

Geruzak manipulatzeko oinarriak ikasi dituzunez, errazago ulertuko duzu geruzak nolako tresna indartsuak diren Dia-n diagramak eraikitzeko.

Geruzek zertarako balio duten ulertzeak ikaragarri lagunduko dizu zure diagramen kalitatea eta efektu bisuala hobetzen.

Esate baterako, pentsa ezazu objektu asko dituen diagrama bat eraikitzen ari zarela (diagrama elektrikoa, edo UMLa edo horrelakoren bat). Objektu guztiak geruza berean (hau da, atzeko planokoan) ipintzen badituzu, lan pixka bat egindakoan zirriborro ulertezin bat izango duzu eskuartean. Aldaketak egiteak buruko mina emango dizu, denbora asko beharko duzu hor erdian azaltzen den objektu hori nahaste-borraste horretako zein objekturekin dagoen konektatuta asmatzeko, eta abar.

Baina Dia-k Diagrama egituratuak eraikitzen dituenez, diagrama guztiak naturalki egituratuko dira, zati txikitan banatuta egongo dira, erraz kudea ditzazun, objektu-bloke monolitiko bakar batekin borrokan jardun beharrean.

[Oharra] Oharra

Definizioz, diagramek egituratuak izan behar dute, zati logikotan banatzea uste baino errazagoa izan dadin. Horregatik dira hain garrantzizkoak geruzak. Geruzen bidez zati bakoitza isola dezakezu diapositiba bat balitz bezala, lasai eta gustura manipulatzeko moduan.

Hasteko, geruzei izena alda dakieke diagramako zein zati adierazten duten argitzeko, eta besteen artean errazago aurkitzeko. Eta gainera, geruzak erakutsi edo ezkutatu egin daitezke, unean ikustea komeni denaren arabera.

Diagrama egiten ari zarenean edozein unetan geruza bati izena aldatzeko, egin klik bikoitza geruzaren izenean Geruzen elkarrizketa-koadroan. Geruza-atributuen elkarrizketa-koadroa agertuko da, eta hor aldatu ahal izango diozu izena.

[Iradokizuna] Iradokizuna

Saiatu izen ulergarri eta argi bat ezartzen, zertarako sortu zenuen errazago gogoratzeko. Ez izan beldurrik diagraman geruza asko sortzeko, Dia-k ez du mugarik ezartzen geruzen kopuruan, eta gainera lasai egokitu dezakezu hierarkia zure premien arabera.

Geruzaren izenaren ondoan dagoen Begiaren ikonoa oso erosoa da geruza ezkutatu edo bistaratzeko.. Geruza bat ez bistaratzea erabakitzen baduzu, egin klik Begiaren ikonoan, eta geruza eta barnean duen guztia desagertu egingo dira Oihaletik.

Geruza batzuk bakarrik ikustea praktikoa da diagramaren zati bat bakarrik manipulatu nahi duzunean, gainerakoa ukitu gabe. Diagrama hainbat orrialdetan inprimatu nahi baduzu, edo zati baten diseinua aldatzen duten ezarpenak probatu nahi badituzu ere, era horretan lan egin dezakezu. Lasai esperimentatu geruzekin. Ongi konfiguratzen badituzu, zure diagramak askoz ere itxura hobea izango du.

[Oharra] Oharra

Dia-n, Geruzak sortzea eta manipulatzea diagramako objektuak marraztea edo hautatzea bezain normala da. Geruzak erabiltzen ohitu egin beharko duzu, diagrama bat sortzen duzun bakoitzean erabili beharko baitituzu seguruenik.


Atala 10. Egileak

Dia Alexander Larsson-ek idatzia da, eta James Henstridge-k egiten ditu mantentze-lanak. Dia-ri buruzko informazio gehiago nahi izanez gero, bisitatu web gune ofiziala: live.gnome.org/Dia. Bidali zure iruzkin, iradokizun eta akatsen berri-emateak GNOMEren akatsen segimendurako datu-basera. (Programa-erroreen berri emateko jarraibideak linean aurkituko dituzue.) GNOMEren 1.1 bertsioa edo berriagoa baduzu, Programa-erroreen berri emateko tresna (bug-buddy) ere erabil dezakezu akatsen berri emateko. Tresna hori Menu nagusiko Utilitateak azpimenuan duzu eskuragarri.

Eskuliburu honen egileak Henry House (<hajhouse@houseag.com>) , Judith Samson (<judith@samsonsource.com>), eta Kevin Breit (<battery841@mypad.com>) dira. Eskuliburu honi buruzko ohar edo iradokizunik baduzu, bidal ezazu mesedez GNOMEren dokumentazio-proiektura, <docs@gnome.org> helbidera mezu bat bidaliz. Linean ere bidal daitezke oharrak, GNOMEren dokumentazioaren egoeraren taularen bidez.

Hizkuntza Politikarako Sailburuordetza <hizkpol@ej-gv.es> (euskarazko itzulpena) Itzulpenari buruzko oharrik baduzu, <email>hizkpol@ej-gv.es</email> helbidera bidal ditzakezu.


Atala 11. Lizentzia

Edukien aurkibidea

11.1. Lizentzia


11.1. Lizentzia

Programa hau software librea da; birbana eta/edo alda dezakezu, Free Software Foundation-ek argitaratutako GNU Lizentzia Publiko Orokorraren 2. bertsioan, edo (nahiago baduzu) bertsio berriago batean, jasotako baldintzak betez gero.

Programa hau erabilgarria izango delakoan banatzen da, baina INOLAKO BERMERIK GABE; era berean, ez da bermatzen beraren egokitasuna MERKATURATZEKO edo HELBURU PARTIKULARRETARAKO ERABILTZEKO. Argibide gehiago nahi izanez gero, ikus GNU Lizentzia Publiko Orokorra.

GNU Lizentzia Publiko Orokorraren kopia GNOMEren erabiltzailearen gidaren eranskinean daukazu. GNU Lizentzia Publiko Orokorraren kopia Free Software Foundation-en bidez ere lor dezakezu haren web gunea bisitatuz edo hona idatziz:

Free Software Foundation, Inc. 59 Temple Place - Suite 330 Boston, MA 02111-1307 USA