Dia-Handbuch

Kevin Breit

Henry House

Judith Samson

Alan Horkan

Thomas Harding

Mark Dexter

Steffen Macke

Dies ist Version 0.97.2 des Dia-Handbuches.

Copyright © 2004, 2009, 2010, 2011 Kevin Breit, Henry House, Judith Samson, Alan Horkan, Mark Dexter, Steffen Macke

Es wird die Erlaubnis gewährt, dieses Dokument zu kopieren, zu verteilen und/oder zu modifizieren, unter den Bestimmungen der GNU Free Documentation License, Version 1.2 oder jeder späteren Version, veröffentlicht von der Free Software Foundation; ohne unveränderliche Abschnitte, ohne vordere Umschlagtexte und ohne hintere Umschlagtexte. Eine Kopie der Lizenz wird im Abschnitt mit dem Titel "GNU Free Documentation License" bereitgestellt.

CSS Stylesheets, die in diesem Dokument referenziert werden und die Grafiken, die in diesen Stylesheets referenziert werden, unterliegen einer anderen Lizenz.

Versionsgeschichte
Version 0.97.2 | 2011-05-13 | sdteffen
Zweite, erweiterte deutsche Version des Dia-Handbuches
Version 0.97.1 | 2009-12-12 | sdteffen
Erste deutsche Version des Dia-Handbuches

Inhaltsverzeichnis

1. Einleitung
1.1. Einleitung
2. Schnellstart
2.1. Was können Sie tun?
2.2. Dia starten
2.3. Zeichenfläche erzeugen
2.4. Ein Diagramm erstellen
2.5. Speichern und Drucken von Diagrammen
2.6. Dia in der Kommandozeile ausführen
2.7. Wem nützt Dia?
3. Die Zeichenfläche
3.1. Einführung zur Zeichenfläche
3.2. Gitternetzlinien
3.3. Lineale
3.4. Hintergrundfarbe
3.5. Zoomen
3.6. Andere Ansichts-Optionen
3.7. Rückgängig und Wiederholen
4. Objekte und der Werkzeugkasten
4.1. Überblick über Dias Werkzeugkasten
4.1.1. Werkzeug "Objekte verändern"
4.1.2. Textbearbeitung-Werkzeug
4.1.3. Vergrößern-Werkzeug
4.1.4. Werkzeug "Diagramminhalt verschieben"
4.1.5. Grundlegende Objekte
4.1.6. Spezielle Objekte
4.1.7. Vorausgewählte Farbe, Strichstärke und Linienart
4.2. Objekte benutzen
4.2.1. Objekte hinzufügen
4.2.2. Objekte bewegen
4.2.3. Objektgrößen ändern
4.2.4. Objekte löschen
4.2.5. Objekte mit Linien verbinden
4.2.6. Texteingabe
4.2.7. Objekte ausrichten
4.2.7.1. Wie Objekte ausgerichtet werden können
4.2.7.2. Linksbündige, rechtsbündige und zentrierte Ausrichtung
4.2.7.3. Ausrichtungsoptionen Oben, Mitte und Unten
4.2.7.4. Horizontal und vertikal verteilen
4.2.7.5. Angrenzende und gestapelte Ausrichtung
4.2.8. Objekte gruppieren
4.3. Objekteigenschaften
4.3.1. Quellen der Standardeigenschaften
4.3.2. Objekteigenschaften ändern
4.3.2.1. Eigenschaften eines Objektes ändern
4.4. Farben
4.4.1. Farbauswahldialog
4.5. Diagrammbaum
4.5.1. Den Diagrammbaum öffnen
4.5.2. Mit dem Diagrammbaum arbeiten
5. Standardobjekte
5.1. Einführung in die Standardobjekte
5.1.1. Text
5.1.2. Rechteck
5.1.3. Ellipse
5.1.4. Vieleck
5.1.5. Beziergon
5.1.6. Linie
5.1.7. Bogen
5.1.8. Zickzacklinie
5.1.9. Linienzug
5.1.10. Bezierlinie
5.1.11. Linieneigenschaften
5.1.11.1. Linienbreite
5.1.11.2. Linienfarbe
5.1.11.3. Linienstil
5.1.11.4. Pfeile
5.1.12. Bild
5.1.13. Kontur
6. Spezialisierte Objekte
6.1. Spezialisierte Objekte
6.1.1. Kategorien von spezialisierten Objekten
6.1.1.1. Vermischtes
6.1.1.2. Chemietechnik
6.1.1.3. Chronogramm
6.1.1.4. Schaltkreis
6.1.1.5. Cisco - Computer
6.1.1.6. Cisco - Versch.
6.1.1.7. Cisco - Netzwerk
6.1.1.8. Cisco - Switch
6.1.1.9. Cisco - Telefon
6.1.1.10. Bauwesen
6.1.1.11. Kybernetik
6.1.1.12. Electronic
6.1.1.13. ER
6.1.1.14. Flussdiagramm
6.1.1.15. FS (Funktionsstruktur)
6.1.1.16. GRAFCET
6.1.1.17. RE-i*
6.1.1.18. RE-Jackson
6.1.1.19. RE-KAOS
6.1.1.20. Karte, isometrisch
6.1.1.21. Diverse
6.1.1.22. MSE
6.1.1.23. Netzwerk
6.1.1.24. Leiter
6.1.1.25. Pneumatik/Hydraulik
6.1.1.26. SADT
6.1.1.27. SDL
6.1.1.28. Sybase
6.1.1.29. UML
6.1.2. Objekte und Objektbögen organisieren
7. Objekte auswählen
7.1. Grundsätzliches zur Objektauswahl
7.2. Wie Objekte ausgewählt werden
7.2.1. Ein einzelnes Objekt auswählen
7.2.2. Objektauswahl aufheben
7.2.3. Mehrere Objekte auswählen
7.2.3.1. Shift+Klick Auswahl
7.2.3.2. Rechteckauswahl
7.2.3.3. Alles auswählen
7.2.3.4. Nichts auswählen
7.2.3.5. Auswahl umkehren
7.2.3.6. Transitive Auwahl
7.2.3.7. Verbundene auswählen
7.2.3.8. Auswahl "Gleicher Typ"
7.3. Arbeit mit ausgewählten Objekten
7.3.1. Operationen mit allen gewählten Objekten
7.3.1.1. Ausgewählte Objekte verschieben
7.3.1.2. Kopieren, Ausschneiden, Einfügen, Duplizieren, Löschen
7.3.1.3. Mit individuellen Objekten arbeiten
7.3.1.4. Eine Objektgruppe erzeugen
8. Diagramme laden und speichern
8.1. Einleitung Laden und Speichern
8.2. Dateitypen
8.2.1. Native Dia Diagrammdateien
8.2.2. Importformate
8.2.3. Exportieren: Unterstützung anderer Formate
13. Autoren
14. Lizenz
14.1. Lizenz
A. GNU Free Documentation License

Abbildungsverzeichnis

1.1. Flussdiagramm-Beispiel
2.1. Netzwerk-Beispieldiagramm
2.2. Leere Zeichenfläche
3.1. Diagrammeigenschaften / Gitter
3.2. Knopf "Einrasten am Gitter"
3.3. Lineal mit rot eingekreisten Pfeilen
3.4. Hintergrundfarbe ändern
3.5. Vergrößern-Werkzeug
3.6. Zoomen der Zeichenfläche
3.7. Zoom-Optionen im Menü Ansicht
3.8. Menü Ansicht
4.1. Dias Werkzeugkasten
4.2. Werkzeug "Objekte verändern"
4.3. Vergrößern-Werkzeug
4.4. Werkzeug "Diagramminhalt verschieben"
4.5. Spezielle Objekte
4.6. Vorausgewählte Farbe, Strichstärke und Linienart
4.7. "Farben zurücksetzen"-Knopf
4.8. "Farben wechseln"-Knopf
4.9. Vorausgewählte Strichstärke
4.10. Pfeil und Linienart
4.11. Objekt-Handgriffe
4.12. Linien-Handgriffe
4.13. Linie verbunden
4.14. Fester Verbindungspunkt
4.15. Zentraler Verbindungspunkt
4.16. Werkzeug "Textbearbeitung"
4.17. Text-Befehle im Menü "Bearbeiten"
4.18. Menü Objekte / Ausrichten
4.19. Vor dem linkbündigen Ausrichten
4.20. Linksbündig ausgerichtet
4.21. Zentriert ausgerichtet
4.22. Rechtsbündig ausgerichtet
4.23. Vor Ausrichtung Oben
4.24. Ausrichtung Oben
4.25. Ausrichtung Mitte
4.26. Ausrichtung Unten
4.27. Vor "Horizontal verteilen"
4.28. Nach "Horizontal verteilen"
4.29. Vor "Vertikal verteilen"
4.30. Nach "Vertikal verteilen"
4.31. Ausrichtung / Angrenzend
4.32. Ausrichtung / Gestapelt
4.33. Vor und nach der Gruppierung
4.34. Vorgaben Texteigenschaften
4.35. Vorgaben Rechteckeigenschaften
4.36. Farbauswahlliste
4.37. Farbauswahldialog
4.38. Diagrammbaum mit Kontextmenü
4.39. Sortieroptionen im Diagrammbaum
5.1. Standardobjekte
5.2. Kontextmenü Zickzacklinie
5.3. Kontextmenü Linienzug
5.4. Kontextmenü Bezierlinie
5.5. Linieneigenschaften
5.6. Linienfarbe
5.7. Linienstil
5.8. Pfeile
5.9. Bild
6.1. Vermischtes
6.2. Cisco - Computer
6.3. Cisco - Verschiedenes
6.4. Cisco - Netwerk
6.5. Cisco - Switch
6.6. Cisco - Telefon
6.7. Flussdiagramm
6.8. Diverse
6.9. Netzwerk
6.10. UML
6.11. Eigenschaften der UML-KLasse
6.12. Objektbögen und Objekte
7.1. Ausgewähltes Objekt
7.2. Rechteckauswahlbeispiel
7.3. Menü "Auswahl"


Kapitel 1. Einleitung

Inhaltsverzeichnis

1.1. Einleitung


1.1. Einleitung

Dia ist eine Anwendung zur Erstellung von technischen Diagrammen. Dia erlaubt es unter anderem, über mehrere Seiten verteilte Diagramme zu drucken, es exportiert in viele Formate (u.a. PDF, VDX, SVG, EPS, CGM und PNG) und bietet die Möglichkeit, benutzerdefinierte Objekte zur Symbolpalette hinzuzufügen. Dia bietet die Möglichkeit, UML-Diagramme, Netzwerkpläne und Flussdiagramme zu erstellen (Eine Vielzahl an weiteren Diagrammtypen wird unterstützt).

Dieses Dokument beschreibt Dia in der Version 0.97.1.

Abbildung 1.1. Flussdiagramm-Beispiel


Kapitel 2. Schnellstart

Inhaltsverzeichnis

2.1. Was können Sie tun?
2.2. Dia starten
2.3. Zeichenfläche erzeugen
2.4. Ein Diagramm erstellen
2.5. Speichern und Drucken von Diagrammen
2.6. Dia in der Kommandozeile ausführen
2.7. Wem nützt Dia?

Dieses Schnellstart-Kapitel soll Ihnen helfen, Diagramme zu erstellen, ohne das komplette Handbuch zu lesen.


2.1. Was können Sie tun?

Dia ist eine Zeichenanwendung, die es erlaubt, eine Vielzahl an Diagrammen zu erstellen. Dia ist einfach zu erlernen und dabei flexibel genug, um erfahrenen Anwendern die Erzeugung hochgradig angepasster Diagramme zu ermöglichen. Im folgenden sind zwei einfache Diagramme dargestellt, die schnell mit Dia gezeichnet werden können.

Abbildung 2.1. Netzwerk-Beispieldiagramm


2.2. Dia starten

Sie können Dia aus dem Hauptmenü (Startmenü) starten, indem Sie auf das Dia-Symbol klicken. Alternativ können Sie auf ein im Dia-Format vorliegendes Diagramm klicken, oder dia in der Kommandozeile eingeben.


2.3. Zeichenfläche erzeugen

Alle Diagramme werden auf Ihrer eigenen Zeichenfläche gezeichnet. Wenn Sie Dia zum ersten Mal starten, wird automatisch eine leere Zeichenfläche angelegt. Sie können jederzeit eine neue Zeichenfläche erzeugen, indem Sie den Menüpunkt Datei->Neues Diagramm aufrufen. Die Zeichenfläche kann in verschiedener Hinischt angepasst werden, beispielsweise durch eine Änderung der Hintergrundfarbe oder mit Gitternetzlinien. Das Kapitel Die Zeichenfläche enthält weitere Informationen zur Anpassung der Zeichenfläche.

Dia mit leerer Zeichenfläche und Werkzeugkasten links.

Abbildung 2.2. Leere Zeichenfläche


2.4. Ein Diagramm erstellen

Ein Diagramm besteht aus Objekten. Objekte sind Symbole oder Linien in unterschiedlichen Formen und Farben. Objekte können einfache Linienzeichnungen, Texte oder Farbbilder sein. Einige Objekte erlauben die Texteingabe und -darstellung im Objekt.

Diagramme mit Dia zu erzeugen, ist einfach. Der Werkzeugkasten enthält eine Palette von Objekten, unter anderem einfache Formen, Linien und spezialisierte Objekte. Um ein Objekt zur Zeichenfläche hinzuzufügen, klicken Sie zunächst auf das gewünschte Objekt und anschliessend auf den Punkt in der Zeichenfläche, an dem das Objekt eingefügt werden soll. Nach dem Klick erscheint das Objekt auf der Zeichenfläche. Im Kapitel Objekte hinzufügen finden Sie weitere Informationen zu diesem Thema.

Auf der Zeichenfläche können Objekte durch klicken und ziehen mit der Maus bewegt werden. Durch klicken und ziehen der grünen und roten "TODO_handles" kann die Objektgröße verändert werden. In den Kapitel Objekte bewegen und Objektgrößen verändern finden Sie weiterführende Informationen.

Objekte können durch Linien verbunden werden. Ziehen Sie einfach ein Linienende auf einen Verbindungspunkt eines Objektes (durch ein kleines blaues "x" markiert). Sobald Objekte verbunden sind, verlängert bzw. verkürzt sich die Verbindungslinie, wenn die Objekte bewegt werden. Somit bleiben die Objekte verbunden. Das Kapitel See Objekte mit Linien verbinden beschreibt detailliert, wie sich Objekte verbinden lassen.

Im Werkzeugkasten können Sie durch einen Doppelklick auf ein Objekt dessen vorbelegte Eigenschaften ansehen und bearbeiten. Dadurch können Sie verschiedene Voreinstellungen für das Objekt definieren. Für Objekte, die Texte enthalten, lassen sich Textausrichtung und Schriftarten anpassen. Für Standardobjekte lassen sich Transparenz, Eckenrundung und das Seitenverhältnis anpassen. Im Kapitel Quellen der vorbelegten Eigenschaften können Sie weitere Details nachlesen.

Dia enthält einen Standardsatz von allgemeinen Polygon- und Linienobjekten (mehr dazu im Kapitel Objekte ). Weiterhin enthält Dia eine Anzahl von vordefinierten Objekten für unterschiedliche Zwecke - unter anderem Flussdiagramme, UML Diagramme, Netzwerkpläne und viele andere. Weitere Informationen dazu lesen Sie im Kapitel Spezielle Objekte . Sollte das gewünschte Objekt in Ihrer Dia-Installation fehlen, finden Sie es eventuell im Internet in der Fundgrube für Dia-Objekte. Die dort gelisteten Objekte lassen sich über den grafischen Assistenten diashapes komfortabel installieren.

Viele typische Aufgaben in Dia erfordern die Auswahl eines oder mehrerer Objekte. Dia unterstützt mehrere Arten der schnellen Objektauswahl - im Kapitel Objekte auswählen erfahren Sie näheres.

Dia kann auf unterschiedliche Weise an Ihre Anforderungen angepasst werden.

Folien ermöglichen es, ein Diagramm in mehrere übereinanderliegende Ebenen zu gliedern und diese Ebenen unabhängig voneinander zu bearbeiten.

Dia macht es Nutzern einfach, eigene (benutzerdefinierte) Objekte zu erstellen. Das Kapitel


2.5. Speichern und Drucken von Diagrammen

Dia bietet die Standard-Funktionen zum speichern und drucken, zu finden sind sie im Datei-Menü. Die Auswahl des Menüpunktes Datei -> Seiteneinrichtung erlaubt es Papiergröße, -ausrichtung und Druckränder zu wählen. Der Seiteneinrichtungsdialog erlaubt es auch, zu wählen, ob ein Diagramm massstäblich (Prozenteingabe) gedruckt werden soll oder ob es auf eine feste größe (in Zentimetern) skaliert werden soll.

Dia unterstützt eine Vielzahl von Formaten, die sich exzellent zur Veröffentlichung im Internet eignen. Unter anderem:

  • Computer Graphics Metafile (.cgm)
  • Eingebettetes Postscript (.eps)
  • Dia Format (.dia)
  • Portable Network Graphics (.png)
  • Visio (.vdx)
  • Scalable Vector Graphics (.svg)

Im Kapitel Laden und Speichern von Diagrammen finden Sie weitere Informationen zu den von Dia unterstützten Dateiformaten.


2.6. Dia in der Kommandozeile ausführen

Dia kann von der Kommandozeile ausgeführt werden. Dadurch kann Dia in Stapelverarbeitungsdateien genutzt werden.


2.7. Wem nützt Dia?

Dia kann von vielen Leuten in unterschiedlichen Branchen genutzt werden.

  • Ein Systementwickler kann SADT-Diagramme zur Systemanalyse und -entwurf erstellen.

  • Ein Anforderungsingenieur kann beispielsweise RE-KAOS, RE-Jackson oder RE-I*-Diagramme erzeugen.

  • Ein Softwareentwickler kann verschiende Arten von UML-Diagramme zeichnen und diese mit der Flexibilität eines universellen Zeichenprogrammes erweitern. Auch Programmablaufpläne können mit Dia erzeugt werden.

  • Ein Datenbankspezialist kann Relationen in ER-Diagramme visualisieren.

  • Ein Betriebsingenieur kann Kybernetik-Diagramme erzeugen.

  • Ein Netzwerkadministrator kann einen Überblick des Firmennetzwerkes entwerfen.

  • Ein Elektroingenieur kann Dia nutzen, um elektrische Schaltkreise zu erläutern.

  • Ein Maschinenbauingenieur kann hydraulische und pneumatische Schemata zeichnen.

  • Ein Bauingenieur kann statische Systeme mit Dia skizzieren.


Kapitel 3. Die Zeichenfläche

Inhaltsverzeichnis

3.1. Einführung zur Zeichenfläche
3.2. Gitternetzlinien
3.3. Lineale
3.4. Hintergrundfarbe
3.5. Zoomen
3.6. Andere Ansichts-Optionen
3.7. Rückgängig und Wiederholen


3.1. Einführung zur Zeichenfläche

Dias Zeichenfläche ist der Fensterbereich, der das Diagramm enthält. Alle Zeichenobjekte werden auf der Zeichenfläche platziert und arrangiert.


3.2. Gitternetzlinien

Gitternetzlinien sind mit den Linien des Millimeterpapiers vergleichbar. Sie erlauben es dem Nutzer, Zeichenobjekte auszurichten. Die Gitternetzlinien können durch die Auswahl von Ansicht -> Gitter anzeigen im Menü temporär deaktiviert werden.

Gitternetzlinien können über den im Menü unter Datei -> Diagrammeigenschaften erreichbaren Dialog (siehe untenstehende Abbildung) angepasst werden.

Diagrammeigenschaften / Gitter

Abbildung 3.1. Diagrammeigenschaften / Gitter

Falls das Häkchen bei "Dynamisches Gitter" gesetzt ist, passen sich die Gitternetzlinien automatisch an, sobald Sie in das Diagramm hinein- oder hinauszoomen. Der auf der Zeichenfläche sichtbare Abstand der Gitternetzlinien bleibt dabei konstant. Ausserdem deaktiviert das Dynamische Gitter die anderen Gitternetzkonfigurationsoptionen.

Wenn das Dynamische Gitter deaktiviert ist, bleibt der Abstand der Gitternetzlinien konstant. Sobald Sie in das Diagramm hinein- oder herauszoomen wird sich der auf der Zeichenfläche sichtbare Abstand der Gitternetzlinien verändern, das Gitter wird dichter oder weniger dicht erscheinen.

Der horizontale (X) und vertikale (Y) Abstand der Gitternetzlinien kann in Zentimetern eingegeben werden oder durch die Knöpfe mit Pfeilsymbol vergrößert bzw. verkleinert werden. Neben den sichtbaren Gitternetzlinien bitet Dia unsichtbare Gitternetzlinien, die ebenfalls zur Ausrichtung von Zeichenobjekten genutzt werden können. Der Wert "Sichtbarer Abstand" gibt das Verhältnis von sichtbaren zu unsichtbaren Gitternetzlinien an. Beträgt der Wert 1, so sind alle Gitternetzlinien sichtbar. Beträgt er 2, so ist jede zweite Gitternetzlinie sichtbar.

Durch das Setzen des Häkchens bei "Sechseckgitter" kann ein Sechseckgitter statt des Rechteckgitters genutzt werden. Die Gittergröße wird ebenfalls in Zentimetern angegeben.

Das "Einrasten am Gitter" kann über einen Knopf in der Werkzeugleiste über der Zeichenfläche ein- und ausgeschaltet werden. Ist es eingeschaltet, so werden Zeichenobjekte bei der Bewegung gezwungen, sich an den Gitternetzlinien auszurichten.

Knopf "Einrasten am Gitter"

Abbildung 3.2. Knopf "Einrasten am Gitter"


3.3. Lineale

Lineale am oberen und linken Rand der Zeichenfläche angezeigt. Sie zeigen die Größe der Zeichenfläche in Zentimetern. Dabei muss ein angezeigter Zentimeter nicht unbedingt einen Zentimeter auf dem Bildschirm entsprechen. Wie groß ein Zentimeter der Zeichenfläche auf dem Bildschirm erscheint, ist vom gewählten Zoomfaktor und der Monitorauflösung in DPI abhöngig. Bei einer Monitorauflösung von 96 DPI und einem Zoomfaktor von 185% wird beispielsweise wird ein Zentimeter auf der Zeichenfläche ein Zentimeter auf dem Monitor entsprechen. Unabhängig von diesen Einstellungen können Sie mit dem Bildschirmlineal immer die Größe der Zeichenobjekte abmessen.

[Anmerkung] Anmerkung

Wenn Sie ein Diagramm drucken und die Skalierung auf 100% einstellen, wird das Diagramm immer massstabsgetreu gedruckt - unabhöngig von der Auflösung des Druckers oder dem Zoomfaktor der Zeichenfläche.

Jedes Lineal hat einen beweglichen Pfeil, der die exakte Mauskoordinate angibt. Wenn der Nutzer beispielsweise die Maus nach oben bewegt, wird sich der Pfeil des rechten Lineals mitbewegen. Diese Pfeile sind nützlichen, wenn Zeichenobjekte an einer exakt an einem definierten Punkt positioniert werden müssen.

Lineal mit rot eingekreisten Pfeilen

Abbildung 3.3. Lineal mit rot eingekreisten Pfeilen

Lineale können durch die Auswahl von Ansicht -> Lineale anzeigen temporär ausgeblendet werden. Anders als Gitternetzlinien können Lineale nicht per Voreinstellung für neue Dokumente deaktiviert werden.


3.4. Hintergrundfarbe

Die Option "Hintergrundfarbe" erlaubt es Ihnen, die Farbe der Zeichenfläche zu ändern. Die voreingestellte Farbe ist Weiss. Sie können die Farbe durch die Auswahl von Datei -> Diagrammeigenschaften und die Auswahl des Reiters "Farben". Die Hintergrundfarbe ist die erste Option. Die Hintergrundfarbe kann durch das Öffnen der Auswahlliste mit Ihrer Standardfarbauswahl geändert werden. Unter Objekte / Farben finden Sie weitere Informationen zur Farbauswahl.

Abbildung 3.4. Hintergrundfarbe ändern

[Anmerkung] Anmerkung

Die Gitternetzlinien werden Ihre Farbe automatisch ändern, um sichtbar zu bleiben, wenn Schwarz als Hintergrundfarbe gewählt wird.


3.5. Zoomen

Zoomen erlaubt es dem Nutzer, heranzuzoomen (Dinge größer zu machen) oder wegzuzoomen (Dinge kleiner zu machen). Heranzoomen ist nützlich, wenn Sie versuchen, sehr präzise zu zeichnen. Wegzoomen ist hilfreich, wenn Sie einen größeren Ausschnitt des Diagrames sehen wollen.

Die Zeichenfläche kann bis 2500% heran- und bis 5% weggezoomt werden. Es gibt unterschiedliche Möglichkeiten, zu zoomen.

Abbildung 3.5. Vergrößern-Werkzeug

Der Werkzeugkasten enthält ein Vergrößern-Werkzeug. Wenn Sie das Werkzeug auswählen und irgendwo auf die Zeichenfläche klicken, wird mit Faktor 2 herangezoomt (beispielsweise von 100% auf 200%) und die Zeichenfläche um den Klickpunkt zentriert. Halten Sie die Shift-Taste während des Klicks gedrückt, so wird der Vorgang umgekehrt (mit Faktor 2 weggezoomt).

Zoomen der Zeichenfläche

Abbildung 3.6. Zoomen der Zeichenfläche

Dia besitzt eine Zoom-Auswahlliste in der Werkzeugleiste. Diese Auswahlliste erlaubt es, einen Zoomfaktor einzugeben oder aus einer Liste vorgegebener Faktoren zu wählen.

Zoom-Optionen im Menü Ansicht

Abbildung 3.7. Zoom-Optionen im Menü Ansicht

Das Menü Ansicht hat Optionen für Heranzoomen (Strg++), Wegzoomen (Strg+-), eine Auswahl von Zoomfaktoren und Einpassen (Strg+E).

[Tipp] Tipp

Die Tastenkombination Strg+E (Einpassen) ist sehr nützlich, um das gesamte Diagramm in das Fenster einzupassen. Sie ermöglicht auch eine schnelle Prüfung, um zu sehen, ob es Objekte ausserhalb der momentan sichtbaren Zeichenfläche gibt.


3.6. Andere Ansichts-Optionen

Abbildung 3.8. Menü Ansicht

Neben den oben erwähnten Zoom-Optionen bietet das Menü Ansicht weitere nützliche Funktionen. Diese werden im Folgenden diskutiert.

  • Vollbild (F11) schaltet zwischen dem normalen Fenster und der Vollbild-Ansicht um.

  • Kantenglättung schaltet die Kantenglättung ein und aus.

  • Gitter anzeigen schaltet die Gitternetzlinien ein und aus.

  • Am Gitter einrasten schaltet das Einrasten am Gitter ein und aus.

  • An Objekten einrasten schaltet das Einrasten an Objekten ein und aus. Wenn diese Option aktiviert ist, können Linien durch Ziehen des Linienendpunktes auf ein Objekt mit dem Hauptverbindungspunkt des Objektes verbunden werden. Wenn diese Option deaktiviert ist, müssen Linienenden auf den Hauptverbindungspunkt gezogen werden, um eine Verbindung herzustellen.

  • Lineale anzeigen schaltet die Linealanzeige ein oder aus.

  • Verbindungspunkte anzeigen schaltet die Verbindungspunktanzeige ein oder aus.

  • Neue Ansicht öffnet einen neuen Reiter, der das gleiche Diagramm anzeigt. Dies kann nützlich sein, wenn Sie verschiedene Teile des Diagramms gleichzeitig sehen und bearbeiten wollen.

    [Tipp] Tipp

    Wenn Sie "Neue Ansicht" oder "Ansicht klonen" nutzen, um das Diagramm in einem zweiten Reiter zu öffnen, werden Änderungen sofort im anderen Reiter angezeigt. Falls Sie das Diagramm in zwei Instanzen öffnen (z.B. mit Datei / Öffnen), müssen Sie die Änderungen der einen Instanz speichern und die zweite Instanz neu laden, um die Änderungen in der zweiten Instanz zu sehen. Deshalb sollten Sie normalerweise "Neue Ansicht" oder "Ansicht klonen" bevorzugen.

  • Ansicht klonen verhält sich wie "Neue Ansicht", kopiert aber Zoom und Zeichenfläche der Ausgangsansicht, statt die voreingestellten Werte zu verwenden.

  • Einpassen zoomt automatisch zum größtmöglichen Zoomfaktor, der es erlaubt das komplette Diagramm im Fenster darzustellen.

  • Aktualisieren zeichnet das Diagramm auf die Zeichenfläche. Dies ist normalerweise nicht notwendig. Falls der Zeichenflächeninhalt einmal nicht aktuell ist (beispielsweise ein Teil einer gelöschten Linie noch sichtbar ist), wählen Sie "Aktualisieren".


3.7. Rückgängig und Wiederholen

Dia unterstützt Rückgängig und Wiederholen bei den meisten Operationen. Um eine Operation rückgängig zu machen, drücken Sie Strg+Z oder wählen Sie Bearbeiten->Rückgängig aus dem Menü. Um eine Operation zu wiederholen, drücken Sie Strg+Shift+Z oder wählen Sie Bearbeiten->Wiederholen im Menü.


Kapitel 4. Objekte und der Werkzeugkasten

Inhaltsverzeichnis

4.1. Überblick über Dias Werkzeugkasten
4.1.1. Werkzeug "Objekte verändern"
4.1.2. Textbearbeitung-Werkzeug
4.1.3. Vergrößern-Werkzeug
4.1.4. Werkzeug "Diagramminhalt verschieben"
4.1.5. Grundlegende Objekte
4.1.6. Spezielle Objekte
4.1.7. Vorausgewählte Farbe, Strichstärke und Linienart
4.2. Objekte benutzen
4.2.1. Objekte hinzufügen
4.2.2. Objekte bewegen
4.2.3. Objektgrößen ändern
4.2.4. Objekte löschen
4.2.5. Objekte mit Linien verbinden
4.2.6. Texteingabe
4.2.7. Objekte ausrichten
4.2.7.1. Wie Objekte ausgerichtet werden können
4.2.7.2. Linksbündige, rechtsbündige und zentrierte Ausrichtung
4.2.7.3. Ausrichtungsoptionen Oben, Mitte und Unten
4.2.7.4. Horizontal und vertikal verteilen
4.2.7.5. Angrenzende und gestapelte Ausrichtung
4.2.8. Objekte gruppieren
4.3. Objekteigenschaften
4.3.1. Quellen der Standardeigenschaften
4.3.2. Objekteigenschaften ändern
4.3.2.1. Eigenschaften eines Objektes ändern
4.4. Farben
4.4.1. Farbauswahldialog
4.5. Diagrammbaum
4.5.1. Den Diagrammbaum öffnen
4.5.2. Mit dem Diagrammbaum arbeiten

Ein Diagramm in Dia besteht aus einer Menge an Objekten. Objekte sind vor- oder benutzerdefinierte Symbole. Der Werkzeugkasten erlaubt es, die gewünschten Objekte zu wählen und Voreinstellungen der Objekteigenschaften vorzunehmen


4.1. Überblick über Dias Werkzeugkasten

4.1.1. Werkzeug "Objekte verändern"
4.1.2. Textbearbeitung-Werkzeug
4.1.3. Vergrößern-Werkzeug
4.1.4. Werkzeug "Diagramminhalt verschieben"
4.1.5. Grundlegende Objekte
4.1.6. Spezielle Objekte
4.1.7. Vorausgewählte Farbe, Strichstärke und Linienart

Abbildung 4.1. Dias Werkzeugkasten

Wenn Dia ausgeführt wird, befindet sich der Werkzeugkasten auf der linken Seite des Fensters (Es gibt auch die Möglichkeit, Werkzeugkasten und Zeichenfläche in getrennten Fenstern darzustellen). Der Werkzeugkasten enthält Objektpaletten und andere Kontrollelemente. Der Werkzeugkasten ist in drei Regionen unterteilt. Die obere Region enthölt 16 Knöpfe, mit den ersten vier lässt sich das Diagramm manipulieren, die folgenden 12 sind grundlegende Zeichenobjekte.

Der mittlere Teil des Werkzeugkastens enthölt den gewählten Objektbogen. Mit ihm lassen sich Objekte aus einer Vielzahl von mitgelieferten Objektbögen wählen, beispielsweise Flussdiagramm, Netzwerk, UML, uvm.

Der untere Teil des Werkzeugkastens enthält Kontrollelemente um Einstellungen für Objekte zu treffen, die zur Zeichenfläche hinzugefügt werden. Diese Einstellungen beinhalten Vordergrundfarbe, Hintergrundfarbe und Linienstärke. Drei Kontrollelemente erlauben es, Linieneigenschaften zu definieren: Anfangspfeil, Linienart und Endpfeil.


4.1.1. Werkzeug "Objekte verändern"

Werkzeug "Objekte verändern"

Abbildung 4.2. Werkzeug "Objekte verändern"

Das Werkzeug "Objekte verändern" ist vorausgewählt, wenn Dia gestartet wird. Dieses Werkzeug erlaubt es, ein oder mehrere Objekte auf der Zeichenfläche auszuwählen. Nachdem ein Objekt der Zeichenfläche hinzugefügt wurde, wird das Werkzeug "Objekte verändern" automatisch ausgewählt. Dadurch ist es einfach, ein Objekt zur Zeichenfläche hinzuzufügen und dann mit der Arbeit fortzufahren, ohne das Werkzeug "Objekte verändern" neu auszuwählen.

[Tipp] Tipp

Mit der Leerzeichentaste kann zwischen einem Objektwerkzeug und dem Werkzeug "Objekt verändern" gewechselt werden. Falls Sie beispielsweise dem Diagramm mehrere Rechteck-Objekte hinzufügen wollen: Klicken Sie zuerst auf das Rechteck-Symbol und dann auf die Zeichenfläche, um das Rechteck einzufügen. Dadurch wird das Werkzeug "Objekt verändern" automatisch ausgewählt. Um das Rechteck-Werkzeug wieder auszuwählen, drücken Sie die Leerzeichentaste.Sie können jetzt wieder in der Zeichenfläche klicken, um ein zweites Recheck hinzuzufügen. Fahren Sie fort, die Leerzeichentaste zu drücken und zu klicken, um die gewünschte Anzahl an Rechtecken hinzuzufügen.

[Tipp] Tipp

Sie können Dia anpassen und die automatische Auswahl des Werkzeuges "Objekt verändern" deaktivieren. Unter


4.1.2. Textbearbeitung-Werkzeug

Bevor das Textbearbeitung-Werkzeug genutzt werden kann, muss zunächst ein entsprechendes Objekt, beispielsweise ein Textobjekt, zur Zeichenfläche hinzugefügt werden. Das Textbearbeitung-Werkzeug kann auch durch das Drücken der Taste "F2" aktiviert werden und bleibt aktiv, bis die Taste "Esc" gedrückt wird.


4.1.3. Vergrößern-Werkzeug

Abbildung 4.3. Vergrößern-Werkzeug

Das Vergrößern-Werkzeug ist eine Möglichkeit heran- und wegzuzoomen. Unter Die Zeichenfläche / Zoomen finden Sie weitere Informationen. Das Vergrößern-Werkzeug bleibt aktiv, bis Sie ein anderes Werkzeug aktivieren.


4.1.4. Werkzeug "Diagramminhalt verschieben"

Werkzeug "Diagramminhalt verschieben"

Abbildung 4.4. Werkzeug "Diagramminhalt verschieben"

Das Werkzeug "Diagramminhalt verschieben" wird genutzt, um sich im Diagramm zu bewegen. Wenn dieses Werkzeug aktiviert ist, wird der Mauszeiger zu einer Hand und durch Klicken und Ziehen kann man das Diagramm in der Zeichenfläche verschieben. Das Werkzeug "Diagramminhalt verschieben" bleibt aktiv, bis ein anderes Werkzeug ausgewählt wird. Durch das drücken der Taste "S" lässt sich das Werkzeug auswählen.


4.1.5. Grundlegende Objekte

Die auf "Objekt verändern", Textbearbeitung, Vergrößern und "Diagramminhalt verschieben" folgenden 12 Knöpfe erlauben es, grundlegende Objekte auf der Zeichenfläche zu platzieren. Unter Einführung in grundlegende Objekte finden Sie weiterführende Informationen dazu.


4.1.6. Spezielle Objekte

Abbildung 4.5. Spezielle Objekte

Im Werkzeugkasten befindet sich unterhalb der grundlegenden Objekte eine Auswahlliste, die es erlaubt Objektbögen mit speziellen Zeichenobjekten zu wählen. Wie in der obenstehenden Abbildung ersichtlich, wird Dia mit einer großen Anzahl an speziellen Objekten ausgeliefert. Um ein spezielles Objekt zu nutzen, wählen Sie zunächst den gewünschten Objektbogen in der Auswahlliste. Dann klicken Sie auf das gewäschte Objekt und anschliessend auf die Zeichenfläche, um das Objekt einzufügen. Unter Kategorien von speziellen Objekten finden Sie Informationen darüber, welche speziellen Objekte verfügbar sind.


4.1.7. Vorausgewählte Farbe, Strichstärke und Linienart

Vorausgewählte Farbe, Strichstärke und Linienart

Abbildung 4.6. Vorausgewählte Farbe, Strichstärke und Linienart

Unter der Palette von speziellen Objekten befinden sich Elemente, um Vorder- und Hintergrundfarbe, Linienstärke und -art vorzubelegen. Diese Elemente definieren Voreinstellungen, die genutzt werden, wenn neue Objekte zur Zeichenfläche hinzugefügt werden. Sie beeinflussen nicht die Eigenschaften von bereits auf der Zeichenfläche vorhandenen Objekten. Die getroffenen Einstellungen bleiben für alle zukünftigen Dia-Sitzungen aktiv - bis sie geändert werden.

Die beiden Rechtecke links erlauben es, Vorder- und Hintergrundfarben für alle zur Zeichenfläche hinzugefügten Objekte vorauszuwählen. Wenn Sie auf das obere Rechteck klicken (das schware in der Abbildung oben), können Sie die Vordergrundfarbe für alle neuen Objekte auswählen. Durch einen Klick auf untere Rechteck können eine Hintergrundfarbe vorauswählen. Unter Objekte / Farben finden Sie weitere Informationen zur Farbauswahl.

[Tipp] Tipp

Abbildung 4.7. "Farben zurücksetzen"-Knopf

Um die Farben auf Schwarz als Vordergrundfarbe und Weiss als Hintergrundfarbe zurückzusetzen, klicken Sie auf den kleinen Knopf links unter der Farbauswahl.

[Tipp] Tipp

Abbildung 4.8. "Farben wechseln"-Knopf

Um Vorder- und Hintergrundfarbe zu tauschen, klicken Sie auf den kleinen Pfeil rechts über den beiden Rechtecken.

Abbildung 4.9. Vorausgewählte Strichstärke

Rechts der beiden Rechtecke befinden sich fünf Linien unterschiedlicher Stärke. Um eine Linienstärke vorauszuwählen, klicken Sie einfach darauf. Ein gestricheltes Rechteck zeigt, welche Strichstärke momentan vorgewählt ist.

Pfeil und Linienart

Abbildung 4.10. Pfeil und Linienart

Am Fuße des Werkzeugkastens befinden sich drei Knöpfe. Der linke Knopf erlaubt die Vorauswahl der Pfeilform für den Linienanfang. In der Abbildung ist die Vorauswahl "Kein Pfeil". Der rechte Knopf erlaubt die Vorauswahl der Pfeilform für das Linienende. Da nur Linien Richtung und Pfeile aufweisen, beeinflussen diese Knöpfe nur Linien und keine anderen Objekte. Der mittlere Knopf erlaubt die Vorauswahl der Linienart (durchgezogen, gestrichelt, usw.).

[Anmerkung] Anmerkung

Die Vorauswahl der Strichstärke und Linienart beeinflusst alle grundlegenden Objekte und einige spezielle Objekte (beispielsweise die des Objektbogens "Flussdiagramm"). Beachten Sie aber, dass einige spezielle Objekte (beispielsweise die des Objektbogens "AADL") feste Strichstärken aufweisen und von diesen Einstellungen nicht beeinflusst werden.


4.2. Objekte benutzen

4.2.1. Objekte hinzufügen
4.2.2. Objekte bewegen
4.2.3. Objektgrößen ändern
4.2.4. Objekte löschen
4.2.5. Objekte mit Linien verbinden
4.2.6. Texteingabe
4.2.7. Objekte ausrichten
4.2.7.1. Wie Objekte ausgerichtet werden können
4.2.7.2. Linksbündige, rechtsbündige und zentrierte Ausrichtung
4.2.7.3. Ausrichtungsoptionen Oben, Mitte und Unten
4.2.7.4. Horizontal und vertikal verteilen
4.2.7.5. Angrenzende und gestapelte Ausrichtung
4.2.8. Objekte gruppieren


4.2.1. Objekte hinzufügen

Objekte können zur Zeichenfläche hinzugefügt werden, indem zunächst auf den entsprechenden Objektsymbolknopf geklickt wird und anschliessend auf den gewünschten Einfügepunkt in der Zeichenfläche. Das gewählte Objekt wird daraufhin an diesem Punkt eingefügt.

[Tipp] Tipp

Sie können schnell mehrere Objekte des gleichen Typs zum Diagramm hinzufügen, indem Sie mit der Leertaste zwischen dem Werkzeug "Objekt verändern" und dem gewünschten Objekt wechseln. Falls Sie beispielsweise dem Diagramm mehrere Rechteck-Objekte hinzufügen wollen: Klicken Sie zuerst auf das Rechteck-Symbol und dann auf die Zeichenfläche, um das Rechteck einzufügen. Dadurch wird das Werkzeug "Objekt verändern" automatisch ausgewählt. Um das Rechteck-Werkzeug wieder auszuwählen, drücken Sie die Leerzeichentaste.Sie können jetzt wieder in der Zeichenfläche klicken, um ein zweites Recheck hinzuzufügen. Fahren Sie fort, die Leerzeichentaste zu drücken und zu klicken, um die gewünschte Anzahl an Rechtecken hinzuzufügen.

[Tipp] Tipp

Falls Sie verschiedene Farben oder Linienarten für verschiedene Objekte nutze, können Sie Zeit sparen, wenn Sie eine separate Datei mit Beispielobjekte anlegen und daraus kopieren, um sie in das bearbeitete Diagramm einzufügen.


4.2.2. Objekte bewegen

Wenn ein Objekt zur Zeichenfläche hinzugefügt wurde, wird es mit kleinen grünen Quadraten (Handgriffen) entlang der Objektgrenze angezeigt.

Abbildung 4.11. Objekt-Handgriffe

Um ein Objekt zu bewegen, klicken Sie irgendwo in das Objekt und ziehen Sie die Maus bei gedrückter Maustaste über die Zeichenfläche. Um eine Linie zu bewegen, müssen Sie auf die Linie klicken.

[Tipp] Tipp

Wenn Sie ein Objekt bewegen, achten Sie darauf, nicht auf einen der Handgriffe zu klicken. Sonst werden Sie die Objektgröße ändern, statt das Objekt zu bewegen.


4.2.3. Objektgrößen ändern

Handgriffe werden genutzt, um Objektgrößen zu ändern. Um ein Objekt zu vergrößern, klicken Sie einfach auf einen Handgriff und ziehen Sie ihn fort vom Zentrum des Objektes, während Sie die Maustaste gedrückt halten. Die Objektgröße wird sich verändern während Sie die Maus bewegen. Falls ein Objekt ein festes Seitenverhältnis aufweist, wird eine Änderung in einer Dimension die andere automatisch ändern. Falls ein Objekt kein festes Seitenverhältnis aufweist, können Sie eine Dimension (beispielsweise die Höhe) ändern, ohne die andere (beispielsweise die Breite) zu beeinflussen. Einige Objekte besitzen die Möglichkeit auszuwählen, ob das Seitenverhältnis beibehalten werden soll.


4.2.4. Objekte löschen

Um ein Objekt aus einem Diagramm zu löschen, wählen Sie das Werkzeug "Objekt verändern" und klicken Sie auf das Objekt in der Zeichenfläche. Die Darstellung der grünen Handgriffe zeigt die Auswahl des Objektes an. Drücken Sie die "Entf"-Taste oder wählen Sie Bearbeiten->Löschen aus dem Menü.


4.2.5. Objekte mit Linien verbinden

In vielen Diagrammen sind Objekte miteinander durch Linien verbunden. Wenn ein Objekt nicht ausgewählt ist, wird eine Reihe von Verbindungspunkten an seinen Grenzen durch kleine "x"-Symbole dargestellt. Es gibt auch einen Hauptverbindungspunkt in der Mitte des Objektes. Auch Linien besitzen Verbindungspunkte, an denen andere Linien verbunden werden können.

Linien besitzen Handgriffe an jedem Ende die benutzt werden, um die Linie mit anderen Objekten zu verbinden. Diese Handgriffe sind grün, falls die Linie nicht verbunden ist und rot falls die Linie verbunden ist. Linien besitzen auch orange Handgriffe, welche genutzt werden, um den Linienverlauf zu formen. Die Abbildung unten zeigt mehrere Linien mit grünen Handgriffen an den unverbundenen Enden und roten Handgriffen an den verbundenen Enden.

Abbildung 4.12. Linien-Handgriffe

Um zwei Objekte mit einer Linie zu verbinden:

  1. Wählen Sie die gewünschte Linie (Linie, Zickzacklinie, usw) durch einen Klick auf das Symbol im Werkzeugkasten.

  2. Sie können entweder auf die Zeichenfläche klicken, um die Linie im Diagramm zu platzieren und dann den Anfangspunkt der Linie zum gewünschten Verbindungspunkt des ersten Objektes zu ziehen.

    Oder Sie sparen einen Schritt durch direkten Klick auf den gewünschten Verbindungspunkt. In diesem Fall wird der Anfangspunkt der Linie bereits beim Einfügen mit dem gewählten Verbindungspunkt des ersten Objektes verbunden.

    In beiden Fällen wird der verbundene Handgriff am Anfangspunkt der Linie in rot dargestellt.

  3. Klicken Sie auf den grünen Handgriff am Endpunkt der Linie und ziehen Sie ihn bei gedrückter Maustaste auf den gewünschten Verbindungspunk des zweiten Objektes. Sobald die Linie verbunden ist, wird das Objekt mit einer roten Umrandung hervorgehoben, wie in untenstehender Abbildung.

    Abbildung 4.13. Linie verbunden

    An diesem Punkt sind die zwei Objekte verbunden. Falls Sie eines der Objekte verschieben, wird die Linie sich verändern, um weiterhin beide Objekte zu verbinden. Falls Sie die Linie verschieben, wird sie sich von beiden Objekten lösen. Falls Sie eine solche Verbindung einmal irrtümlich lösen, können Sie dies durch die Tastenkombination Strg+Z oder durch die Auswahl von Bearbeiten->Rückgänging im Menü rückgängig machen.

Sie könnnen jederzeit eine Verbindung lösen oder mit einem neuen Punkt verbinden, indem sie auf den Start- oder Endpunkt klicken und ihn auf eine neue Position im Diagramm ziehen.

[Tipp] Tipp

Wenn Sie eine Linie mit einem festen Punkt auf dem Umriss des Objektes verbinden, wird sie bei einer Bewegung des Objektes mit diesem Punkt verbunden bleiben.

Abbildung 4.14. Fester Verbindungspunkt

Wenn Sie eine Linie mit dem zentralen Verbindungspunkt verbinden, wird der dargestellte Verbindungspunkt bei einer Bewegung des Objektes automatisch verschoben, er muss nicht geändert werden.

Abbildung 4.15. Zentraler Verbindungspunkt

Beachten Sie, dass, wenn eine Linie mit dem zentralen Verbindungspunkt verbunden haben, der Handgriff trotzdem auf dem Umriss des Objektes positioniert wird. Um den Verbindungspunkt zu verändern, müssen Sie deshalb den Handgriff der Linie verschieben (und nicht den Mittelpunkt des Objektes).

Unter Grundobjekte / Linie finden Sie weitere Informationen über die verfügbaren Linien.


4.2.6. Texteingabe

Text kann mit dem Werkzeug "Textbearbeitung" eingegeben und geändert werden. Sie können das Werkzeug "Textbearbeitung" im Werkzeugkasten auswählen, auf das gewünschte Objekt klicken (es muss die Textbearbeitung unterstützen) und dann den Text tippen. Schriftart, -größe, -ausrichtung und andere Formatierungseinstellungen können mit einem Doppelklick auf das Textobjekt geändert werden.

Abbildung 4.16. Werkzeug "Textbearbeitung"

Alternativ können Sie das Objekt auch mit dem Werkzeug "Objekt verändern" auswählen und dann mit der Taste F2 die Textbearbeitung aktivieren.

Hier einige wichtige Tipps zu Tastaturkürzeln bei der Texteingabe.

Text-Befehle im Menü "Bearbeiten"

Abbildung 4.17. Text-Befehle im Menü "Bearbeiten"

[Tipp] Tipp

Die normalen Tastaturkürzel Kopieren / Ausschneiden / Einfügen (Strg+C, Strg+X, Strg+V) arbeiten mit ganzen Objekten, nicht den Texten. Das Menü "Bearbeiten" enthält die Befehle "Text kopieren", "Text ausschneiden" (Shift+Strg+X) und "Text einfügen" (Shift+Strg+V), um nur die Textinhalte eines Objektes zu kopieren. Bitte beachten Sie, dass, wenn Sie einen Text in Dia einfügen, dieser entsprechend der Objekteigenschaften formatiert wird - unabhängig von der Textquelle.

[Tipp] Tipp

Sie können mit der Maus keinen Textabschnitt innerhalb eines Objektes markieren. Sie können Zeichen an der aktuellen Cursorposition durch Tippen einfügen. Wichtig: Falls das Werkzeug "Textbearbeitung" nicht aktiviert ist, löscht die Taste "Entf" löscht das gesamte Objekt. (Nutzen Sie Strg+Z oder den Menüpunkt Bearbeiten->Rückgängig falls Sie ein Objekt irrtümlich gelöscht haben.) Um den gesamten Text in einem Objekt zu löschen, nutzen Sie den Menüpunkt Bearbeiten->Text ausschneiden (Shift+Strg+X).


4.2.7. Objekte ausrichten

4.2.7.1. Wie Objekte ausgerichtet werden können
4.2.7.2. Linksbündige, rechtsbündige und zentrierte Ausrichtung
4.2.7.3. Ausrichtungsoptionen Oben, Mitte und Unten
4.2.7.4. Horizontal und vertikal verteilen
4.2.7.5. Angrenzende und gestapelte Ausrichtung

Dia bietet verschiedene Optionen zur Ausrichtung einer Anzahl von Objekten - dabei ist es nicht notwendig, Objekte einzeln zu verschieben. Die Optionen sind über den Menüeintrag Objekte->Ausrichten erreichbar und in untenstehender Abbildung dargestellt.

Menü Objekte / Ausrichten

Abbildung 4.18. Menü Objekte / Ausrichten


4.2.7.1. Wie Objekte ausgerichtet werden können

Um Objekte auszurichten, wählen Sie zunächst gewünschten Objekte zusammen aus (Unter Objekte auswählen finden Sie detaillierte Hinweise dazu) und führen dann einen der Ausrichtungsbefehle aus - entweder aus dem Menü heraus oder über ein Tastaturkürzel. Die Reihenfolge, in der Sie die Objekte auswählen spielt dabei keine Rolle.


4.2.7.2. Linksbündige, rechtsbündige und zentrierte Ausrichtung

Die Optionen Links, Zentrieren und Rechts werden genutzt, um vertikal verteilte Objekte auf der Zeichenfläche bündig auszurichten dazu werden die Objekte automatisch horizontal verschoben. Die linksbündige Ausrichtung verschiebt die ausgewählten Objekte so, dass ihre linke Kante sich auf einer Linie befindet. Als Referenz dient dabei das ausgewählte Objekt, welches sich am weitesten links befindet. Analog dazu verschiebt die rechtsbündige Ausrichtung die ausgewählten Objekte so, dass ihre rechte Kante sich auf einer Linie befindet, mit dem ausgewählten Objekt, welches sich am weitesten rechts befindet als Referenz. Die zentrierte Ausrichtung verschiebt die Objekte derart, dass sich ihre Mittelpunkte auf einer vertikalen Linie durch den Mittelpunkt zwischen den horizontal am weitesten auseinanderliegenden Punkten der gewählten Objekte befinden. Beispiele der linksbündigen, rechtsbündigen und zentrierten Ausrichtung sind in den folgenden Abbildungen dargestellt.

Vor dem linkbündigen Ausrichten

Abbildung 4.19. Vor dem linkbündigen Ausrichten

Abbildung 4.20. Linksbündig ausgerichtet

Abbildung 4.21. Zentriert ausgerichtet

Abbildung 4.22. Rechtsbündig ausgerichtet


4.2.7.3. Ausrichtungsoptionen Oben, Mitte und Unten

Die Ausrichtungsoptionen Oben, Mitte und Unten können genutzt werden, um Objekte, die horizontal auf der Zeichnungsfläche verteilt sind, vertikal auszurichten. Die Ausrichtungsoption Oben verschiebt die ausgewählten Objekte derart, dass die obersten Kanten auf einer horizontalen Linie mit dem höchsten Punkt der gewählten Objekte liegen. Analog dazu verschiebt die Ausrichtungsoption Unten die gewählten Objekte so in vertikaler Richtung, dass ihre untersten Kanten auf einer horizontalen Linie durch den tiefsten Punkt der gewählten Objekte liegen. Die Ausrichtungsoption Mitte verschiebt die Objekte derart, dass sich ihre Mittelpunkte auf einer horizontalen Linie durch den Mittelpunkt zwischen den vertikal am weitesten auseinanderliegenden Punkten der gewählten Objekte befinden. Beispiele der Ausrichtungsoptionen Oben, Mitte und Unten sind in den folgenden Abbildungen zu sehen.

Vor Ausrichtung Oben

Abbildung 4.23. Vor Ausrichtung Oben

Abbildung 4.24. Ausrichtung Oben

Abbildung 4.25. Ausrichtung Mitte

Abbildung 4.26. Ausrichtung Unten


4.2.7.4. Horizontal und vertikal verteilen

Die Ausrichtungsfunktionen "Horizontal verteilen" und "Vertikal verteilen" können dazu genutzt werden, die ausgewählten Objekte gleichmässig zu verteilen. Beispiele in den folgenden Abbildungen erläutern die Funktionen.

Vor "Horizontal verteilen"

Abbildung 4.27. Vor "Horizontal verteilen"

Nach "Horizontal verteilen"

Abbildung 4.28. Nach "Horizontal verteilen"

Vor "Vertikal verteilen"

Abbildung 4.29. Vor "Vertikal verteilen"

Nach "Vertikal verteilen"

Abbildung 4.30. Nach "Vertikal verteilen"


4.2.7.5. Angrenzende und gestapelte Ausrichtung

Die Ausrichtungsfunktion "Angrenzend" richtet die gewählten Objekte horizontal so aus, dass kein Raum zwischen ihnen verbleibt. Die Ausrichtungsfunktion "Gestapelt" richtet die gewählten Objekte vertikal so aus, dass kein Raum zwischen ihnen verbleibt. Die folgenden Abbildungen illustrieren diese Funktionen.

Ausrichtung / Angrenzend

Abbildung 4.31. Ausrichtung / Angrenzend

Ausrichtung / Gestapelt

Abbildung 4.32. Ausrichtung / Gestapelt


4.2.8. Objekte gruppieren

Die Gruppierung erlaubt es, mehrere Objekte als Einheit zu behandeln. Eine Gruppe ermöglicht es die Position der gruppierten Objekte zueinander zu fixieren und die Objekteigenschaften in einem Schritt zu ändern. Um eine Objektgruppe zu erstellen, wählen zwei oder mehr Objekte und wählen Objekte->Gruppieren im Menü.

Vor und nach der Gruppierung

Abbildung 4.33. Vor und nach der Gruppierung

Nachdem die Gruppe erstellt wurde und wenn sie später ausgewählt wird, weisen schwarze Handgriffe am Rand auf die Gruppierung hin. Die gesamte Gruppe kann wie ein einzelnes Objekt bewegt werden. Klicken und ziehen Sie dafür einfach eines der gruppierten Objekte.

Durch einen Doppelklick auf ein Objekt einer Gruppe können Sie Eigenschaften Objekte in der Gruppe ändern. Diese Funktionalität steht auch im Kontextmenü über einen rechten Mausklick zur Verfügung. Unter Eigenschaften eines Objektes ändern finden Sie weitere Informationen dazu.


4.3. Objekteigenschaften

4.3.1. Quellen der Standardeigenschaften
4.3.2. Objekteigenschaften ändern
4.3.2.1. Eigenschaften eines Objektes ändern

Die Eigenschaften eines Objektes kontrollieren sein Aussehen. Die Eigenschaften beeinhalten Schriftart und Aussehen, Strichstärke, Linienart, Schriftfarbe, Transparenz (ob der Hintergrund gezeichnet werden soll), Vorder- und Hintergrundfarbe. Weitere Eigenschaften bestimmen, wie ein Objekt dargestellt wird. Dabei weisen unterschiedliche Objekttypen unterschiedliche Eigenschaften auf.

Die Eigenschaften eines Objektes können auf zwei Arten gesetzt werden. Die Standardeinstellungen, die aktiv sind, wenn das Objekt zur Zeichenfläche hinzugefügt wird, bestimmen die initialen Objekteigenschaften. Sobald Objekte im Diagramm platziert wurden, können ihre Eigenschaften über den Eigenschaftendialog des Objektes oder einer Gruppe von Objekten geändert werden.


4.3.1. Quellen der Standardeigenschaften

Die Standardeigenschaften eines Objektes werden in Dia an zwei Stellen verwaltet. Zunächst werden, wie zuvor im Abschnitt Vorausgewählte Farbe, Strichstärke und Linienart beschrieben, eine Vorauswahl von Vorder- und Hintergrundfarbe, der Strichstärke und der Linienart für alle Standardobjekte und einige Spezialobjekte über den Werkzeugkasten voreingestellt. Für Linienobjekte werden auch die Start- und Endpfeile über den Werkzeugkasten vorausgewählt.

Die restlichen Standardeigenschaften eines Objektes können über den "Vorgaben:"-Eigenschaftendialog für jeden Objekttyp individuell festgelegt werden. Dieser Dialog lässt sich über einen Doppelklick auf das Objektsymbol im Werkzeugkasten öffnen. Da die Eigenschaften von Objekt zu Objekt variieren, sieht jeder dieser Vorgabendialoge anders aus. Im folgenden finden Sie Beispiele der Vorgabendialoge für die Standardobjekte Text und Rechteck.

Abbildung 4.34. Vorgaben Texteigenschaften

Abbildung 4.35. Vorgaben Rechteckeigenschaften

Für Objekte, die Text beeinhalten, wird der Vorgabendialog in der Regel die Textausrichtung, Schriftart, Schriftstärke (normal, fett, usw.) und die Schriftgröße. Dadurch ist es möglich, Vorgaben für die Textdarstellung aller Objekte zu treffen, die Texte beinhalten.


4.3.2. Objekteigenschaften ändern

4.3.2.1. Eigenschaften eines Objektes ändern

Sobald Objekte im Diagramm platziert wurden, können Ihre Eigenschaften einzeln oder, falls das Objekt Teil einer Gruppe ist, über die Gruppeneigenschaften geändert werden.


4.3.2.1. Eigenschaften eines Objektes ändern

Um die Eigenschaften eines einzelnen Objektes zu ändern, doppelklicken Sie auf das Objekt. Alternativ können Sie das Kontextmenü des Objektes mit einem Rechtsklick öffnen und dann Eigenschaften... wählen. In beiden Fällen wird der Eigenschaften-Dialog des Objektes angezeigt. Hier können Sie die Objekteigenschaften ändern.

[Anmerkung] Anmerkung

Falls Sie mehrere Objekte oder eine Gruppe von Objekte ausgewählt haben, werden Ihre Änderungen an den Objekteigenschaften für alle gewählten Objekte durchgeführt. Beachten Sie, dass die Anzeige im Eigenschaftendialog primär die Eigenschaften des Objektes anzeigt, auf das Sie geklickt haben. Andere ausgewählte Objekte können durchaus andere Eigenschaften aufweisen, die Sie dann überschreiben.


4.4. Farben

4.4.1. Farbauswahldialog

Alle Objekte in Dia besitzen Farbattribute. Linien weisen eine Linienfarbe auf. Andere Objekte besitzen Linien- und Füllfarbe. Texte und andere Objekte, die Texte beinhalten, besitzen eine Textfarbe. Weiterhin können Sie über den Menüpunkt Datei -> Diagrammeigenschaften die Farben für Hintergrund, Gitterlinien und Seitenumbrüche auswählen. Und der Werkzeugkasten erlaubt die Vorauswahl der Vorder- und Hintergrundfarben von Objekten, die Sie auf der Zeichenfläche einfügen.

In den meisten Fällen gibt es zwei Methoden zur Auswahl von Farben. Zunächst können sie eine Farbe aus einer Liste von Farben in einem Dropdown-Menü auswählen. Ein solches Menü wird für jede Farbeigenschaft angeboten.

Abbildung 4.36. Farbauswahlliste

Die Liste enthält fünf Grundfarben (Schwarz, Weiss, Rot, Grün und Blau The list contains five primary colors (black, white, red, green, and blue) und benutzerdefinierte Farben, die bereits genutzt wurden. Sie können eine der Farben aus der Liste wählen oder den Menüpunkt Weitere Farben ... wählen umd den Farbauswahldialog zu öffnen. Dieser wird im nächsten Abschnitt erläutert.


4.4.1. Farbauswahldialog

Abbildung 4.37. Farbauswahldialog

Der Farbauswahldialog enthält 6 Bereiche:

  1. Das Farbrad erlaubt es, eine Farbe mit der Maus zu wählen. Klicken Sie dazu auf den Farbring. Eine weisse oder schwarze Linie zeigt die aktuelle Position im Ring an. Anschliessend können Sie im Dreieck den gewünschten Farbton durch einen Klick auswählen. Ein weisser oder schwarzer Kreis zeigt die aktuelle Position im Dreieck. Statt zu klicken können Sie den Kreis auch mit der Maus ziehen. Die aktuell gewählte Farbe sehen Sie im rechten Rechteck unterhalb des Farbrades.

  2. Unter dem Farbrad befinden sich zwei farbige Rechtecke. Das Linke zeigt die aktuelle Farbe des Objektes, das Rechte die neu gewählte Farbe (die Sie beispielsweise im Farbrad gewählt haben). Durch einen Klick auf den OK-Knopf wird diese Farbe dem Objekt zugewiesen.

    Neben den Rechtecken befindet sich ein "Pipette"-Knopf. Wenn Sie auf den Knopf klicken, wird aus dem Mauszeiger eine Pipette und Sie können auf der Zeichenfläche oder in einer anderen Anwendung eine Farbe durch einen Klick aufnehmen.

  3. Unten rechts finden Sie eine vordefinierte Farbpalette. Klicken Sie auf eine der Farben, um diese zu wählen.

  4. Oben in der Mitte finden Sie Einstellungen für Farbton, -sättigung und -wert. Sie können eine Farbe durch Eingabe der Werte oder durch die Nutzung der Größer- bzw. Kleiner-Schaltflächen wählen. Beachten Sie, dass das Farbrad sich entsprechend ändert, wenn Sie hier eine Farbe eingeben.

  5. Auf der rechten Seite befinden sich Einstellungen für Rot, Grün und Blau (RGB). Sie funktionieren wie die Einstellungen Ton, Sättigung und Wert.

  6. In der Mitte des Dialogs befindet sich ein Eingabefeld zur Eingabe von Farben in der hexadezimalen Syntax, die auch in HTML genutzt wird. Unter HTML4.01 colors on http://www.w3.org) finden Sie weitere Informationen zu dieser Farbnotation.


4.5. Diagrammbaum

4.5.1. Den Diagrammbaum öffnen
4.5.2. Mit dem Diagrammbaum arbeiten

Der Diagrammbaum bietet eine weitere Art, mit dem Diagramm zu arbeiten. Das Dialogfenster stellt eine Liste aller Objekte im Diagramm dar. Durch einen Rechtsklick auf die Objekte können Sie ein Kontextmenü mit verschiedenen Operationen öffnen.


4.5.1. Den Diagrammbaum öffnen

Der Diagrammbaum lässt sich durch die Auswahl des Menüpunktes Datei -> Diagrammbaum öffnen und schliessen. Alternativ können Sie die Taste "F8" drücken.


4.5.2. Mit dem Diagrammbaum arbeiten

Operationen im Diagrammbaum beeinflussen die Zeichenfläche. Wenn Sie auf einen Diagrammnamen im Diagrammbaum doppelklikcne, wird das entsprechende Diagramm auf der Zeichenfläche aktiv. Wenn Sie auf Objekt im Diagrammbaum klicken, wird dieses auf der Zeichenfläche ausgewält - genauso als hätte Sie auf der Zeichenfläche darauf geklickt. Durch einen Rechtsklick auf ein Objekt im Diagrammbaum wird ein Kontextmenü wie in der folgenden Abbildung geöffnet.

Diagrammbaum mit Kontextmenü

Abbildung 4.38. Diagrammbaum mit Kontextmenü

Die Optionen des Kontextmenüs werden im Folgenden erläutert.

  • "Auffinden" verschiebt das Diagramm so, dass das gewählte Objekt auf der Zeichenfläche sichtbar wird. Dies kann nützlich sein, um ein Objekt in einem komplexen Diagramm zu finden.

  • "Eigenschaften" öffnet den Eigenschaftendialog des gewählten Objektes. Unter Objekteigenschaften finden Sie weitere Informationen zu diesem Dialog.

  • "Diesen Typ verbergen" wird alle Objekte dieses Typs im Diagrammbaum verstecken. Die Objekte existieren allerdings weiter im Diagramm.

  • "Objekttyp zeigen" listet die im Diagrammbaum verborgenen Objekttypen und erlaubt es, diese wieder einzublenden.

  • "Objekte sortieren" öffnet das unten aufgeführte Untermenü.

    Sortieroptionen im Diagrammbaum

    Abbildung 4.39. Sortieroptionen im Diagrammbaum

    • "nach Namen" sortiert den Baum des gewählte Diagramms nach in Objekten eingegebenen Texten.
    • "nach Typ" sortiert den Baum des gewählte Diagramms nach Objekttypen (Rechteck, Linie, usw.).
    • "wie eingefügt" sortiert den Baum des gewählten Diagramms anhand des Zeitpunktes, an dem die Objekte in das Diagramm eingefügt wurden.
    • "alle nach Namen" sortiert den komplette Diagrammbaum nach in den eingegebenen Texten.
    • "alle nach Typ" sortiert den kompletten Diagrammbaum nach Objekttypen.
    • "alle wie eingefügt" sortiert den kompletten Diagrammbaum anhand des Zeitpunktes, an dem die Objekte in die Diagramme eingefügt wurden.
    • "Vorgabe" erlaubt es eine der der Sortieroptionen als Vorgabe zu wählen. Inital ist die Sortierung "wie eingefügt" gewählt.

  • "Diagramme sortieren" erlaubt es die geöffneten Diagramme zu sortieren. Die Sortierung kann nach Name oder Reihenfolge der Öffnung erfolgen.


Kapitel 5. Standardobjekte

Inhaltsverzeichnis

5.1. Einführung in die Standardobjekte
5.1.1. Text
5.1.2. Rechteck
5.1.3. Ellipse
5.1.4. Vieleck
5.1.5. Beziergon
5.1.6. Linie
5.1.7. Bogen
5.1.8. Zickzacklinie
5.1.9. Linienzug
5.1.10. Bezierlinie
5.1.11. Linieneigenschaften
5.1.11.1. Linienbreite
5.1.11.2. Linienfarbe
5.1.11.3. Linienstil
5.1.11.4. Pfeile
5.1.12. Bild
5.1.13. Kontur


5.1. Einführung in die Standardobjekte

5.1.1. Text
5.1.2. Rechteck
5.1.3. Ellipse
5.1.4. Vieleck
5.1.5. Beziergon
5.1.6. Linie
5.1.7. Bogen
5.1.8. Zickzacklinie
5.1.9. Linienzug
5.1.10. Bezierlinie
5.1.11. Linieneigenschaften
5.1.11.1. Linienbreite
5.1.11.2. Linienfarbe
5.1.11.3. Linienstil
5.1.11.4. Pfeile
5.1.12. Bild
5.1.13. Kontur

Abbildung 5.1. Standardobjekte

Dia bietet ein Dutzend Standardobjekte: Text, Rechteck, Ellipse, Vieleck, Beziergon, Linie, Bogen, Zickzacklinie, Linienzug, Bezierlinie, Bild und Kontur.


5.1.1. Text

Dia unterstützt die Nutzung von Texten als eigenständige Objekte. Texte können nach Klick auf das Textwerkzeug im Werkzeugkasten auf der Zeichenfläche platziert werden. Weitere Hinweise finden Sie im Abschnitt Texteingabe im Kapitel "Objekte benutzen".

[Anmerkung] Anmerkung

Ein Text in Dia kann fast alle im System verfügbaren Schriftarten nutzen. Aber falls Sie planen, ihre Diagramme an Nutzern anderer Plattformen weiterzugeben, sollten Sie sich auf eine gemeinsame Schnittmenge an Schriften beschränken.

Das Textobjekt und viele weitere Objekte erlauben die Texteingabe mit dem Werkzeug "Textbearbeitung". Sie können das Werkzeug "Textbearbeitung" im Werkzeugkasten auswählen, auf das gewünschte Objekt klicken (es muss die Textbearbeitung unterstützen) und dann den Text tippen. Schriftart, -größe, -ausrichtung und andere Formatierungseinstellungen können mit einem Doppelklick auf das Textobjekt geändert werden.


5.1.2. Rechteck

Rechtecke in Dia können jede vom Nutzer gewünschte Grösse annehmen. Weitere Rechteckeigenschaften sind:

  • Eckenradius - Falls dieser Wert ungleich Null ist, wird das Rechteck mit abgerundeten Ecken gezeichnet.

  • "Hintergrund zeichnen" - Entscheidet, ob das Innere des Rechteckes leer bleibt oder mit der Hintergrundfarbe gefüllt wird.


5.1.3. Ellipse

Die Form der Ellipse weist an allen Seiten Rundungen auf. Kreise oder Ovale sind Ellipsen.


5.1.4. Vieleck

Ein Vieleck (auch Polygon genannt) ist eine geschlossene Form, die von geraden Linien begrenzt wird. Das Polygonwerkzeugt erlaubt es jegliche geschlossene Form mit geraden Linien zu zeichnen.


5.1.5. Beziergon

Das Beziergon ähnelt dem Polygon. Allerdings bestehen seine Kanten nicht aus geraden Linien, sondern aus Kurven (Mit den Kurven des Beziergons lassen sich natürlich auch gerade Begrenzungslinien erstellen).


5.1.6. Linie

Einie Linie ist eine einfache gerade Linie. Im Gegensatz zu den im Folgenden erläuterten Linien bietet sie ausser dem Start- und Endpunkt keine weiteren Handgriffe, um ihre Form zu ändern.


5.1.7. Bogen

Ein Bogen ist eine gekrümmte Linie. Ziehen sie den orangenen Handgriff in der Mitte der Linie, um die Krümmung des Bogens zu bestimmen.


5.1.8. Zickzacklinie

Die Abschnitte einer Zickzacklinie verlaufen immer exakt waagerecht oder senkrecht und bilden jeweils einen 90-Grad-Winkel. Wie beim Rechteckobjekt kann ein Eckenradius angegeben werden. Ist dieser ungleich Null, werden die Ecken der Zickzacklinie abgerundet dargestellt.

Die Autoroute-Eigenschaft kann eingeschaltet werden, um Start- und Endpunkt automatisch mit der minimalen Anzahl an Ecken zu verbinden. Falls Sie die den Verlauf der Zickzacklinie manuell über die orangenen Handgriffe ändern, wird die Autoroute-Eigenschaft automatisch auf "Nein" gesetzt. Die Autoroute-Eigenschaft kann über den Eigenschaften-Dialog des Objektes und sein Kontextmenü (rechter Mausklick auf die Zickzacklinie) geändert werden.

Zickzacklinien erlauben es, Segmente hinzufügen oder zu löschen. Das ist nützlich, wenn die Linie um mehrere Ecken geführt wird (zum Beispiel, um andere Objekte zu umrunden) oder um den Pfeil in die gewünschte Richtung zeigen zu lassen. Um ein Segment hinzuzufügen oder zu entfernen, wählen Sie eine Zickzacklinie aus und klicken dann mit der rechten Maustaste auf die Linie. Im Kontextmenü wählen Sie "Segment hinzufügen" oder "Segment löschen".

Abbildung 5.2. Kontextmenü Zickzacklinie


5.1.9. Linienzug

Ein Linienzug hat mehrere Segmente wie eine Zickzacklinie, die einzelnen Abschnitte können aber beliebige Winkel zueinander einnehmen. Wie bei der Zickzacklinie können Sie weitere Segmente durch einen Rechtsklick auf einen ausgewählte Linienzug und die Auswahl von "Segment hinzufügen". Wie die Zickzacklinie weist der Linienzug einen Eckenradius zwischen 0 und 10 auf, wobei 0 zu scharfen Ecken und 10 zu maximal abgerundeten Ecken führt.

Abbildung 5.3. Kontextmenü Linienzug


5.1.10. Bezierlinie

Eine Bezierlinie ist eine Linie mit Kurven. Die Form der Bezierlinie wird durch Klicken und Ziehen der grünen und orangenen Hangriffe bearbeitet. Die grünen Handgriffe liegen immer auf der Linie selbst. Mit den grünen Handgriffen lassen sich Winkel und Kurvenradien bestimmen. Durch das über den Rechtsklick auf eine ausgewählte Bezierlinie zugängliche Kontextmenü lassen sich weitere Segmente hinzufügen. Bei Klick auf einen der grünen Handgriffe lässt sich eine der drei folgenden Konfigurationsmöglichkeiten auswählen.

  • Symmetriekontrolle führt zu symmetrischer Anordnung der beiden orangenen Handgriffe um den gewählten grünen Linienpunkt.

  • Glättekontrolle erlaubt es, die beiden orangenen Handgriffe unterschiedlich weit entfernt vom grünen Linienpunkt zu positionieren. Die Winkel der Kontrolllinien werden aber symmetrisch geführt.

  • Scheitelpunktkontrolle erlaubt es die orangenen Handgriffe unabhängig von einander zu positionieren.

Abbildung 5.4. Kontextmenü Bezierlinie


5.1.11. Linieneigenschaften

5.1.11.1. Linienbreite
5.1.11.2. Linienfarbe
5.1.11.3. Linienstil
5.1.11.4. Pfeile

Alle Linien besitzen die folgenden Eigenschaften: Breite, Farbe, Linienstil und Pfeile. Diese Eigenschaften können über den folgenden Dialog bearbeitet werden.

Abbildung 5.5. Linieneigenschaften


5.1.11.1. Linienbreite

Die Linienbreite wird in Zentimetern gemessen und kann durch direkte Eingabe oder das Klicken der Vergrößern/Verkleinern-Knöpfe.


5.1.11.2. Linienfarbe

Abbildung 5.6. Linienfarbe

Linienfarben werden über die Linienfarbenauswahlliste oder die Auwahl des Punktes "Weitere Farben..." (dieser öffnet den Farbauswahldialog) bestimmt. Unter Farben finden Sie weitere Informationen zur Farbauswahl.


5.1.11.3. Linienstil

Abbildung 5.7. Linienstil

Die Art der Linie (durchgezogen, gepunktet, usw.) kann durch Auswahl einer der gezeigten 5 Optionen bestimmt werden. Falls Sie eine gestrichelte Linien wählen, können Sie auch eine Strichlänge in Zentimetern angeben.s


5.1.11.4. Pfeile

Abbildung 5.8. Pfeile

Die Start- und Endpfeile können über die Auswahlliste im Dialog gewählt werden. Falls Sie keinen Pfeil wünschen, wählen Sie das einfache Linienende am Beginn der Liste.


5.1.12. Bild

Abbildung 5.9. Bild

Ein Diagramm kann neben Objekten auch Bilder enthalten. Um ein Bild zu einem Diagramm hinzuzufügen, klicken Sie das Bildsymbol und anschliessend auf die Zeichenfläche. Es wird zunächst der Platzhalter "Broken Image" eingefügt. Durch einen Doppelklick auf diesen Platzhalter öffnen Sie den Eigenschaftendialog des Bildes. Dort können Sie durch Klick auf den Knopf "Auswählen" die gewünschte Bilddatei bestimmen. Nach einem Klick auf "OK" wird das Bild im Diagramm angezeigt. Sie können die Bildgröße über die grünen Objekthandgriffe ändern.

Die folgenden Bildformate werden in der Regel für Bilder in Dia unterstützt:

  • BMP
  • JPEG
  • PNG
  • SVG
  • XPM
Die genaue Liste ist abhängig von der Systemkonfiguration (den von der Gdk-Pixbuf-Bibliothek unterstützen Formaten).


5.1.13. Kontur

Rotation von Texten ist eine der meistgefragten Fähigkeiten von Dia. Durch das Kontur-Objekte steht diese Funktionalität zur Verfügung. Der Rotationswikel lässt sich über den Eigenschaftendialog bestimmen.


Kapitel 6. Spezialisierte Objekte

Inhaltsverzeichnis

6.1. Spezialisierte Objekte
6.1.1. Kategorien von spezialisierten Objekten
6.1.1.1. Vermischtes
6.1.1.2. Chemietechnik
6.1.1.3. Chronogramm
6.1.1.4. Schaltkreis
6.1.1.5. Cisco - Computer
6.1.1.6. Cisco - Versch.
6.1.1.7. Cisco - Netzwerk
6.1.1.8. Cisco - Switch
6.1.1.9. Cisco - Telefon
6.1.1.10. Bauwesen
6.1.1.11. Kybernetik
6.1.1.12. Electronic
6.1.1.13. ER
6.1.1.14. Flussdiagramm
6.1.1.15. FS (Funktionsstruktur)
6.1.1.16. GRAFCET
6.1.1.17. RE-i*
6.1.1.18. RE-Jackson
6.1.1.19. RE-KAOS
6.1.1.20. Karte, isometrisch
6.1.1.21. Diverse
6.1.1.22. MSE
6.1.1.23. Netzwerk
6.1.1.24. Leiter
6.1.1.25. Pneumatik/Hydraulik
6.1.1.26. SADT
6.1.1.27. SDL
6.1.1.28. Sybase
6.1.1.29. UML
6.1.2. Objekte und Objektbögen organisieren


6.1. Spezialisierte Objekte

6.1.1. Kategorien von spezialisierten Objekten
6.1.1.1. Vermischtes
6.1.1.2. Chemietechnik
6.1.1.3. Chronogramm
6.1.1.4. Schaltkreis
6.1.1.5. Cisco - Computer
6.1.1.6. Cisco - Versch.
6.1.1.7. Cisco - Netzwerk
6.1.1.8. Cisco - Switch
6.1.1.9. Cisco - Telefon
6.1.1.10. Bauwesen
6.1.1.11. Kybernetik
6.1.1.12. Electronic
6.1.1.13. ER
6.1.1.14. Flussdiagramm
6.1.1.15. FS (Funktionsstruktur)
6.1.1.16. GRAFCET
6.1.1.17. RE-i*
6.1.1.18. RE-Jackson
6.1.1.19. RE-KAOS
6.1.1.20. Karte, isometrisch
6.1.1.21. Diverse
6.1.1.22. MSE
6.1.1.23. Netzwerk
6.1.1.24. Leiter
6.1.1.25. Pneumatik/Hydraulik
6.1.1.26. SADT
6.1.1.27. SDL
6.1.1.28. Sybase
6.1.1.29. UML
6.1.2. Objekte und Objektbögen organisieren

Dias spezialisierte Objekte sind zur Darstellung konkreter Symboliken entworfen worden. Die spezialisierten Objekte ind sind "Objektbögen" genannte Kategorien eingeteilt. Der mittlere Abschnitt des Werkzeugkastens erlaubt die Auswahl eines Objektbogens mit spezialisierten Objekten. Wählen Sie einen Objektbogen, so wird dieser im Werkzeugkasten angezeigt und Sie können seine Objekte wie die Standardobjekte in ein Diagramm einfügen. Dia unterstützt zahlreiche vordefinierte Objektkategorien.

Die vordefinierten Objektbögen gruppieren verwandte Objekte, so dass Sie vermutlich die Objekte, die Sie gemeinsam nutzen wollen in einem Objektbogen vereint finden. Es ist allerdings auch einfach möglich, eine Objektbögen zu erstellen oder die vordefinierten Objektbögen zu verändern. Unter Objektbägen und Objekte organisieren finden Sie weitere Informationen dazu.

Es ist ohne Programmierkenntnisse möglich, eigene Objekte zu erstellen.


6.1.1. Kategorien von spezialisierten Objekten

6.1.1.1. Vermischtes
6.1.1.2. Chemietechnik
6.1.1.3. Chronogramm
6.1.1.4. Schaltkreis
6.1.1.5. Cisco - Computer
6.1.1.6. Cisco - Versch.
6.1.1.7. Cisco - Netzwerk
6.1.1.8. Cisco - Switch
6.1.1.9. Cisco - Telefon
6.1.1.10. Bauwesen
6.1.1.11. Kybernetik
6.1.1.12. Electronic
6.1.1.13. ER
6.1.1.14. Flussdiagramm
6.1.1.15. FS (Funktionsstruktur)
6.1.1.16. GRAFCET
6.1.1.17. RE-i*
6.1.1.18. RE-Jackson
6.1.1.19. RE-KAOS
6.1.1.20. Karte, isometrisch
6.1.1.21. Diverse
6.1.1.22. MSE
6.1.1.23. Netzwerk
6.1.1.24. Leiter
6.1.1.25. Pneumatik/Hydraulik
6.1.1.26. SADT
6.1.1.27. SDL
6.1.1.28. Sybase
6.1.1.29. UML


6.1.1.1. Vermischtes

Abbildung 6.1. Vermischtes

Gemischte einfache geometrische Figuren. Die Auswahl der Symbole soll den Nutzern einen Satz an Grundfiguren auf einfache und komfortable Art bereitstellen. Somit muss der Nutzer keine Zeit zur Erstellung dieser grundlegenden Symbole aufwenden. Der Objektbogen enthält Symbole mit festen Seitenverhältnissen wie Kreise, Quadrate und verschiedene Arten von Dreiecken und Kreuzen. Diese Objekte erlauben keine Texteingabe in den Objekten.


6.1.1.2. Chemietechnik

Eine Auswahl von Symbolen zur Darstellung von Prozessen in der Chemietechnik


6.1.1.3. Chronogramm

Objekte zur zeitlichen Darstellung in Zeit- und Datenskalen.


6.1.1.4. Schaltkreis

Ein Objektbogen mit Symbolen zur Darstellung von elektrischen Schaltkreisen.


6.1.1.5. Cisco - Computer

Cisco - Computer

Abbildung 6.2. Cisco - Computer

Der Objekbogen "Cisco - Computer" beinhaltet zahlreiche Objekte zur aus der Computertechnik. Unterschiedliche Rechner wie Server, Arbeitsplatzrechner und mobile Geräte lassen sich symbolisch darstellen.


6.1.1.6. Cisco - Versch.

Cisco - Verschiedenes

Abbildung 6.3. Cisco - Verschiedenes

Der Objektbogen "Cisco - Versch." umfasst eine bunte Auswahl von Symbolen, wie Gebäude, Personen, Satelliten, Antennen.


6.1.1.7. Cisco - Netzwerk

Cisco - Netwerk

Abbildung 6.4. Cisco - Netwerk

Der Objektbogen "Cisco - Netzwerk" umfasst eine breite Palette von Netzwerkgeräten der Firma CISCO.


6.1.1.8. Cisco - Switch

Cisco - Switch

Abbildung 6.5. Cisco - Switch

Der Objektbogen "Cisco - Switch" umfasst eine Auswahl von Switch-Netzwerkgeräten der Firma CISCO.


6.1.1.9. Cisco - Telefon

Cisco - Telefon

Abbildung 6.6. Cisco - Telefon

Der Objektbogen "Cisco - Telefon" beeinhaltet Symbole aus der Telefontechnik.


6.1.1.10. Bauwesen

Der Objektbogen umfasst etliche Symbole aus dem Bauingenieurwesen, so zum Beispiel zu Bautechnik, Statik und Prozesstechnik.


6.1.1.11. Kybernetik

Symbole zur Erstellung von kybernetischen Schaltkreisen.


6.1.1.12. Electronic

Schaltkreissymbole aus der Elektrotechnik.


6.1.1.13. ER

Erlaubt die Erstellung von ER-Diagrammen (Entity Relationship). Entitäten und Beziehungen von relationalen Datenbankmodellen lassen sich in derartigen Diagrammen beschreiben.


6.1.1.14. Flussdiagramm

Abbildung 6.7. Flussdiagramm

Ein Objektbogen mit Symbolen, die oft in Flussdiagrammen genutzt werden. Flussdiagramme werden häufig in der elektronischen Datenverarbeitung, Marketing oder der Ökonomie genutzt. Sie sind für halblineare Darstellungen jeglicher Art, die eine gewisse Planung erfordern, hilfreich. Die Mehrzahl der Objekte im Objektbogen "Flussdiagramm" erlaubt die Texteingabe.


6.1.1.15. FS (Funktionsstruktur)

Erlaubt die Erstellung von Funktionsstrukturdiagrammen. Bitte beachten Sie, dass die Objekte ein Kontextmenü aufweisen, dass über einen rechten Mausklick auf das Objekt im Diagramm zugänglich ist.


6.1.1.16. GRAFCET

GRAFCET - beziehungsweiseIEC 61131-3 SFC Diagramme - werden in der grafischen Programmierung und zur Dokumetation sequentielL Prozesse in der Prozessautomatisierung genutzt.

Das Diagramm zeigt Schritt, Aktion, Übergang un die zum Übergang gehörenden Bedingungen.


6.1.1.17. RE-i*

RE-i*, auch Istar genannt, ist ein agentenbasiertes Rahmenwerk zur Anforderungsmodellierung.


6.1.1.18. RE-Jackson

Das Jackson Software Design (JSD) ist eine Entwurfsmethode für Softwaresysteme.


6.1.1.19. RE-KAOS

Anforderungsermittlung mit Hilfe von KAOS-Diagrammen.


6.1.1.20. Karte, isometrisch

Bausteine, um schematische Karten in einer isometrischen Projektion zu erstellen. Hilfreich, um Navigationsskizzen zu erstellen.


6.1.1.21. Diverse

Abbildung 6.8. Diverse

Diverse Objekte, die in keine der anderen Kategorien passen. Unter anderem Symbole zur Darstellung eines Dateisytems, ein konfigurierbares Gitter und eine analoge Uhr, die sich laufend aktualisiert.


6.1.1.22. MSE

Verschiedene Symbole aus der Kommunikationstechnik, die zur Erstellung von "Mobile Subscriber Equipment"-Diagrammen genutzt werden.


6.1.1.23. Netzwerk

Abbildung 6.9. Netzwerk

Objekte, die von Netzwerkadministratoren zum Entwurf und der Dokumentation von Computernetzwerken genutzt werden.


6.1.1.24. Leiter

Symbole aus der grafischen PLC-Programmierung. Die Schaltkreisobjekte werden in der Prozessautomatisierung eingesetzt.


6.1.1.25. Pneumatik/Hydraulik

Symbole zur Darstellung von pneumatischen und hydraulischen Systemen.


6.1.1.26. SADT

Symbole zur Erstellung von SADT/IDEF0-Diagrammen (Strukturanalyse).


6.1.1.27. SDL

Symbole zur Erstellung von SDL-Diagrammen (Specification and Description Language). SDL-Diagramme werden genutzt, um das Verhalten von interaktiven Systemen über die Zeit zu beschreiben. SDL wird häufig in der Telekommunikation genutzt, kann aber auch zur generellen Beschreibung von Prozesssteuerungen und Echtzeitanwendungen genutzt werden.


6.1.1.28. Sybase

Symbole zur Beschreibung von Systemen aus Sybase-Datenbanken und -Servern.


6.1.1.29. UML

Abbildung 6.10. UML

Unified Modeling Language (UML). UML ist eine häufig genutzte Spezifikation zur visuellen Beschreibung in der objektorientierten Programmierung - insbesondere für größere Projekte. Einige der UML-Objekte, wie beispielsweise die UML-Klasse im folgenden Bild, weisen zahlreiche Eigenschaften auf, die sich über den Eigenschaftendialog bearbeiten lassen.

Eigenschaften der UML-KLasse

Abbildung 6.11. Eigenschaften der UML-KLasse


6.1.2. Objekte und Objektbögen organisieren

Die Gruppierung der Objekte in Objektbögen kann angepasst werden. Falls Sie beispielsweise überwiegend Objekte aus einem Objektbogen nutzen, aber einzelne Objekte aus weiteren Bögen benutzen, können Sie einen kombinierten Objektbogen erstellen, der alle genutzten Objekte enthält. Das Kopieren der Objekte von einem Objektbogen in einen anderen wird im Folgenden erläutert:

  1. Wählen Sie den Menüpunkt Datei->Objektbögen und Objekte. Dadurch wird der unten dargestellte Dialog angezeigt.

    Objektbögen und Objekte

    Abbildung 6.12. Objektbögen und Objekte

  2. Mit der Auswahlliste auf der linken Seite wählen Sie den Objektbogen, aus dem heraus Sie kopieren wollen. Mit der rechten Auswahlliste wählen Sie den Objektbogen, in den hinein Sie kopieren wollen.

  3. Klicken Sie zunächst auf das Objekt, das Sie kopieren möchten und anschliessend auf den Kopieren-Knopf.

  4. Wiederholen Sie die oben genannten Schritte für alle Objekte, die Sie kopieren möchten. Sobald Sie fertig sind, klicken Sie auf "Anwenden", um Ihre Änderungen zu speichern.

Die kopierten Objekte werden von jetzt an im rechten Objektbogen erscheinen. Sie können auch Objekte aus einem Objektbogen entfernen oder in andere Bögen verschieben. Über die "Hoch"- und "Runter"-Knöpfe lässt sich die Reihenfolge der Objekte in einem Objektbogen anpassen.


Kapitel 7. Objekte auswählen

Inhaltsverzeichnis

7.1. Grundsätzliches zur Objektauswahl
7.2. Wie Objekte ausgewählt werden
7.2.1. Ein einzelnes Objekt auswählen
7.2.2. Objektauswahl aufheben
7.2.3. Mehrere Objekte auswählen
7.2.3.1. Shift+Klick Auswahl
7.2.3.2. Rechteckauswahl
7.2.3.3. Alles auswählen
7.2.3.4. Nichts auswählen
7.2.3.5. Auswahl umkehren
7.2.3.6. Transitive Auwahl
7.2.3.7. Verbundene auswählen
7.2.3.8. Auswahl "Gleicher Typ"
7.3. Arbeit mit ausgewählten Objekten
7.3.1. Operationen mit allen gewählten Objekten
7.3.1.1. Ausgewählte Objekte verschieben
7.3.1.2. Kopieren, Ausschneiden, Einfügen, Duplizieren, Löschen
7.3.1.3. Mit individuellen Objekten arbeiten
7.3.1.4. Eine Objektgruppe erzeugen


7.1. Grundsätzliches zur Objektauswahl

Die Auswahl eines oder mehrerer Objekte ist eine häufig wiederkehrende Aufgabe bei der Arbeit mit Dia. Wann immer Sie Objekte verschieben, kopieren, löschen oder anderweitig bearbeiten wollen, müssen Sie es zunächst auswählen. Sie können auch mit einer Auswahl mehrerer Objekte arbeiten - zum Beispiel, um eine Gruppe zusammengehörender Objekte zu verschieben und dabei die Anordnung der Objekte untereinander unverändert zu lassen oder um die Eigenschaften einer Gruppe von Objekten zu ändern.

Objekte können auf unterschiedliche Art ausgewählt werden, beispielsweise durch einen Mausklick, die Auwahl einer Fläche oder über den Menüpunkt Auswahl. In diesem Kapitel lernen Sie verschiedene Arten der Objektauswahl kennen.


7.2. Wie Objekte ausgewählt werden

7.2.1. Ein einzelnes Objekt auswählen
7.2.2. Objektauswahl aufheben
7.2.3. Mehrere Objekte auswählen
7.2.3.1. Shift+Klick Auswahl
7.2.3.2. Rechteckauswahl
7.2.3.3. Alles auswählen
7.2.3.4. Nichts auswählen
7.2.3.5. Auswahl umkehren
7.2.3.6. Transitive Auwahl
7.2.3.7. Verbundene auswählen
7.2.3.8. Auswahl "Gleicher Typ"


7.2.1. Ein einzelnes Objekt auswählen

Um ein einzelnes Objekt auszuwählen, können Sie das Werkzeug "Objekte verändern" wählen und anschliessend auf das gewünschte Objekt klicken. Neu auf der Zeichenfläche platzierte Objekte werden automatisch ausgewählt.

Sobald ein Objekt ausgewählt ist, werden sein Handgriffe (kleine grüne und rote Quadrate) angezeigt. Sobald das Objekt ausgewählt wurde, können Sie mit ihm arbeiten. Um den Eigenschaften-Dialog des Objektes aufzurufen, können sie das Objekt doppelklicken oder nach einem Rechtsklick den Punkt "Eigenschaften" des Kontextmenüs wählen.

Abbildung 7.1. Ausgewähltes Objekt


7.2.2. Objektauswahl aufheben

Die Auswahl eines oder mehrerer Objekte kann durch einen Klick auf einen leeren Teil der Zeichenfläche oder durch die Auswahl anderer Objekte aufgehoben werden. Dadurch werden die grünen und roten Handgriffe des Objektes ausgeblendet. Auch durch die Auswahl einer anderen Ebene oder das Anlegen einer neuen Ebene über den Menüpunkt "Ebenen" wird die komplette Objektauswahl aufgehoben.


7.2.3. Mehrere Objekte auswählen

7.2.3.1. Shift+Klick Auswahl
7.2.3.2. Rechteckauswahl
7.2.3.3. Alles auswählen
7.2.3.4. Nichts auswählen
7.2.3.5. Auswahl umkehren
7.2.3.6. Transitive Auwahl
7.2.3.7. Verbundene auswählen
7.2.3.8. Auswahl "Gleicher Typ"

Die Auswahl mehrerer Objekte ist nützlich, wenn Sie die gleiche Operation mit zwei oder mehr Objekten durchführen wollen. Nach der Auwahl können Sie diese Objekten auf unterschiedliche Art bearbeiten. Im Abschnitt Arbeit mit ausgewählten Objekten finden Sie dazu weitere Informationen.

Dia bietet verschiedene Möglichkeiten, um mehrere Objekte auszuwählen. Diese werden im Folgenden beschrieben. Beachten Sie, dass ein Klick auf einen leeren Teil der Zeichenfläche oder ein Klick auf ein nicht ausgewähltes Objekt die Auswahl aller gewählten Objekte aufhebt.


7.2.3.1. Shift+Klick Auswahl

Eine einfache Methode, um zwei oder mehr Objekte gleichzeitig auszuwählen, ist es, bei gewähltem Werkzeug "Objekte verändern", die Shift-Taste gedrückt zu halten, während Sie mit der Maus auf die gewünschten Objekte klicken (Shift-Klick). Dabei sorgt ein Shift-Klick auf ein bisher nicht ausgewähltes Objekt dafür, dass dieses der zur Auswahl hinzugefügt wird, währen ein Shift-Klick auf ein bereits ausgewähltes Objekt dazu führt, dass dieses aus der Auswahl entfernt wird.

[Tipp] Tipp

Sie können Shift-Klick mit jeder im Folgenden beschriebenen Methode kombinieren, um weitere Objekte zur Auswahl hinzuzufügen oder bereits ausgewählte Objekte wieder abzuwählen.

[Anmerkung] Anmerkung

Wenn Sie mehrere Objekte ausgewählt haben, ist es weiterhin möglich, einzelne Objekte zu bearbeiten ohne die anderen gewählten Objekte zu beeinflussen. Im Abschnitt Arbeit mit ausgewählten Objekten finden Sie weitere Informationen dazu.


7.2.3.2. Rechteckauswahl

Sie können alle Objete innerhalb eines rechteckigen Bereiches der Zeichenfläche auswählen, indem Sie den Mauszeiger links oberhalb des linken oberen Objektes platzieren und dann bei gedrückter Maustaste den Mauszeiger nach rechts unten bewegen, bis alle gewünschten Objekte sich in dem erzeugten Auswahlrechteck befinden. Das Auswahlrechteck wird temporär durch eine dünne gestrichelte Linie angedeutet - diese Linie wird nicht Bestandteil des Diagramms. Beachten Sie, dass nur die Objekte ausgewählt werden, die sich komplett im Auswahlrechteck befinden. Objekte, die sich nur teilweise im Auswahlrechteck befinden, werden nicht ausgewählt. Die folgende Grafik verdeutlicht den Rechteckauswahlmechanismus an einem Beispiel.

Nur Objekte, die sich komplett im Rechteck befinden, sind ausgewählt.

Abbildung 7.2. Rechteckauswahlbeispiel

[Tipp] Tipp

Sie können mehrere Regionen mit der Rechteckauswahl selektieren. Vorher ausgewählte Objekte werden ausgewählt bleiben, solange Sie die Auswahl nicht verwerfen (beispielsweise durch einen Doppelklick auf eine leere Region der Zeichenfläche oder durch einen Klick auf ein nicht gewähltes Objekt ohne die Shift-Taste) Wie oben erwähnt, können Sie jederzeit mit Shift+Klick einzelne Objekte an- oder abwählen.

[Tipp] Tipp

Normalerweise führt die Auswahl von oben-links nach unten-rechts zum selben Ergebnis wie ein "entgegengesetztes Ziehen" - ausgehend von der Ecke unten-rechts zur Ecke rechts-oben. Allerdings können Sie eine Option in Dia aktivieren, die es erlaubt nur schneidende Objekte zu wählen, wenn Sie "entgegengesetzt Ziehen".


7.2.3.3. Alles auswählen

Das unten gezeigte Auwahlmenü bietet sechs Optionen zur Auswahl mehrerer Objekte. Die erste Option ist "Alle".

Abbildung 7.3. Menü "Auswahl"

Sie können alle Objekte auf der Zeichenfläche durch die Auswahl des Menüpunktes Auswahl->Alles oder mit Strg+A selektieren. Dadurch werden alle Objekte ausgewählt, egal ob sie momentan sichtbar sind oder nicht.

[Anmerkung] Anmerkung

Wie mit jeder anderen Auswahlmethode werden nur die Objekte der aktuellen Ebene gewählt - sofern Sie mit Ebenen arbeiten.


7.2.3.4. Nichts auswählen

Auswahl->Keine wird alle Objekte abwählen. Hat denselben Effekt wie ein Doppelklick auf eine leere Region der Zeichenfläche.


7.2.3.5. Auswahl umkehren

Diese Auswahl erlaubt es alle Objekte bis auf die aktuell selektierten Objekte auszuwählen. Stellen Sie sich beispielsweise vor, dass Sie 20 Objekte haben und alle bis auf zwei auswählen möchten. Sie können dies tun, imdem Sie (1) die beiden Objekte, die ausschliessen wollen wählen und dann (2) den Menüpunkt Auswahl->Umkehren wählen oder Strg+I drücken. Dadurch werden die zwei momentan gewählten Objekte abgewählt und die 18 nicht ausgewählten Objekte selektiert.

[Tipp] Tipp

Eine weitere Möglichkeit, dies zu tun, ist, den Menüpunkt Auswahl->Alle (oder Strg+A zu drücken) und dann die zwei nicht benötigten Objekte mit Shift+Klick abzuwählen.


7.2.3.6. Transitive Auwahl

Objekte in Dia können durch Linien verbunden werden. Die transitive Auwahl erlaubt es Objekte danach auszuwählen, wie sie miteinander verbunden sind.

Die Option "transitive Auswahl" wählt alle Objekte, die direkt oder indirekt mit dem aktuell ausgewählten Objekten verbunden sind. Um diese Option zu nutzen, selektieren Sie ein oder mehrere Objekte und wählen Auswahl->Transitiv aus dem Menü. Alle Objekte, die mit den initial ausgewählten Objekten verbunden sind, werden zur Auswahl hinzugefügt.


7.2.3.7. Verbundene auswählen

Diese Option ähnelt der Transitiven mit der Ausnahme, dass nur die direkt mit den ausgewählten Objekten verbundenen Objekte zur Auswahl hinzugefügt werden. Um diese Option zu nutzen, wählen Sie zunächst ein oder mehrere Objekte aus. Dann wählen Sie Auswahl->Verbundene Alle Objekte, die direkt mit den momentan ausgewählten Objekten verbunden sind, werden zur Auswahl hinzugefügt.

[Anmerkung] Anmerkung

Die "Verbundene Auswahl" erstreckt sich nur über eine Ebene. Falls beispielsweise Rechteck A über eine Linie mit Rechteck B verbunden ist und Rechteck A ausgewählt ist, wird Auswahl->Verbundene nur die Linie auswählen. Durch einen weiteren Aufruf von Auswahl->Verbundene wird auch Rechteck B zur Auswahl hinzugefügt.

Sie können über den Menüpunkt Auswahl->Transitiv alle verbundenen Objekte in einem Schritt auswählen.


7.2.3.8. Auswahl "Gleicher Typ"

Diese Option erlaubt es Ihnen alle Objekte auszuwählen, die vom gleichen Typ wie das momentan gewählte Objekt sind. Um diese Option zu nutzen, selektieren Sie ein oder mehrere Objekte und wählen Auswahl->Gleicher Typ aus dem Menü. Alle Objekte, die vom gleichen Typ sind wie eines der gewählten Objekte, werden zur Auswahl hinzugefügt.

Falls Sie beispielsweise alle Linienobjekte in Ihrem Diagramm auswählen wollen, selektieren Sie ein Linienobjekt und wählen dann Auswahl->Gleicher Typ aus dem Menü, um alle anderen Linienobjekte auszuwählen.

[Tipp] Tipp

Der Menüpunkt Auswahl->Gleicher Typ kann mit dem Menüpunkt Objekte->Gruppieren um schnell die Eigenschaften aller Objekte eines Typs in Ihrem Diagramm zu ändern.

[Anmerkung] Anmerkung

Die Objekttypen müssen exakt übereinstimmen. Eine Linie und eine Zickzacklinie sind beispielsweise unterschiedliche Typen.


7.3. Arbeit mit ausgewählten Objekten

7.3.1. Operationen mit allen gewählten Objekten
7.3.1.1. Ausgewählte Objekte verschieben
7.3.1.2. Kopieren, Ausschneiden, Einfügen, Duplizieren, Löschen
7.3.1.3. Mit individuellen Objekten arbeiten
7.3.1.4. Eine Objektgruppe erzeugen

Sobald Sie Objekte ausgewählt haben, können Sie mehrere Dinge mit diesen Objekten tun.


7.3.1. Operationen mit allen gewählten Objekten

7.3.1.1. Ausgewählte Objekte verschieben
7.3.1.2. Kopieren, Ausschneiden, Einfügen, Duplizieren, Löschen
7.3.1.3. Mit individuellen Objekten arbeiten
7.3.1.4. Eine Objektgruppe erzeugen

Die folgenden Operationen können mit allen gewählten Objekten in einem Schritt durchgeführt werden.


7.3.1.1. Ausgewählte Objekte verschieben

Sie können die gewählten Objekte als Gruppe verschieben, ohne die relative Position der Objekte zueinander zu verändern. Um dies zu tun, klicken Sie in ein Objekt, das Bestandteil der Auswahl ist und ziehen die Auswahl an die gewünschte neue Position. Achten Sie darauf, dass nicht auf einen Handgriff klicken.


7.3.1.2. Kopieren, Ausschneiden, Einfügen, Duplizieren, Löschen

Sie können die genannten Operationen aus dem Menü "Bearbeiten" auch mit einer Auswahl von Objekten durchführen. Falls Sie beispielsweise die gewählten Objekte duplizieren wollen, wählen Sie Bearbeiten / Duplizieren oder drücken Sie Strg+D. Eine Kopie der gewählten Objekte wird auf der Zeichenfläche eingefügt - links unterhalb der ursprünglich gewählten Objekte. Beachten Sie, dass, falls Sie mehrere Objekte duplizieren oder einfügen, nur die neu eingefügten Objekte ausgewählt bleiben.


7.3.1.3. Mit individuellen Objekten arbeiten

Durch Beschränkungen in der Implementierung werden einige Operationen mit Einzelobjekten in einer Auswahl weiterhin nur die Einzelobjekte verändern. Seit Dia 0.97 wurde diese Inkonsistenz aufgehoben und der Eigenschaftendialog erlaubt es, mehrere Objekte gleichzeitig zu ändern - ohne dieser zunächst zu gruppieren.

Die Handgriffe der Einzelobjekte verändern Ihr Verhalten, wenn eine Auswahl existiert (sie werden deshalb etwas dunkler dargestellt). Statt die Größe eines einzelnen Objektes zu ändern, können die Handgriffe genutzt werden, um alle ausgewählten Objekte zu bewegen oder am Gitter einzurasten - unter Am Gitter einrasten finden Sie weitere Details dazu.

[Tipp] Tipp

Wenn Sie den Eigenschaften-Dialog aufrufen, achten Sie darauf, den Doppelklick nicht auf der leeren Zeichenfläche durchzuführen, sonst werden alle Objekte abgewählt.


7.3.1.4. Eine Objektgruppe erzeugen

Wie oben erwähnt, ist es einfach, Objekte auszuwählen und ebenso einfach, eine Auswahl versehentlich durch einen Doppelklick auf eine leere Stelle der Zeichenläche zu verlieren. Falls Sie eine bestimmte Auswahl von Objekten permanent so gruppieren wollen, dass Sie diese Auswahl nicht versehentlich verlieren können, sollten Sie eine Objektgruppe erzeugen. Wählen Sie Objekte->Gruppieren um aus einer Auswahl von Objekte eine Gruppe zu erzeugen Um eine Gruppierung aufzuheben, selektieren Sie die Gruppe und wählen dann Objekte->Gruppierung aufheben aus dem Menü. Unter Objekte Gruppieren finden Sie weitere Informationen zu Objektgruppen.


Kapitel 8. Diagramme laden und speichern

Inhaltsverzeichnis

8.1. Einleitung Laden und Speichern
8.2. Dateitypen
8.2.1. Native Dia Diagrammdateien
8.2.2. Importformate
8.2.3. Exportieren: Unterstützung anderer Formate


8.1. Einleitung Laden und Speichern

Dia folgt demselben Modell wie die meisten Desktop-Anwendungen: Sie müssen alle Zeichenflächen, die Sie später weiterverwenden wollen, explizit speichern. Um eine Datei zu speichern, wählen Sie Datei->Speichern aus dem Menü. Es wird der Speicherdialog angezeigt. Ihr Diagramm wird im Dia XML-Format gespeichert. Da die Dateiendung nicht verändert wird, ist es eine gute Idee darauf zu achten, dass der Dateiname auf ".dia" endet.

Um ein zuvor von Dia oder einer anderen Anwendung gespeichertes Diagramm zu laden, wählen Sie Datei->Öffnen aus dem Menü. Im Dialog Diagramm öffnen wählen Sie die gewünschte Datei und klicken auf Öffnen. Der Dialog Diagramm öffnen enthält eine Auswahlliste Dateityp bestimmen. Falls Dia das Dateiformat nicht automatisch erkennen kann, wählen Sie den gewünschten Dateityp (beispielsweise Dia XML).

Eine alternative Möglichkeit, Dateien zu laden, ist es Dia über die Kommandozeile zu starten und die zu öffnende Datei als Argument anzugeben.


8.2. Dateitypen

8.2.1. Native Dia Diagrammdateien
8.2.2. Importformate
8.2.3. Exportieren: Unterstützung anderer Formate

Einige Worte über Dateitypen. Sie sollten sich bewusst sein, dass nicht alle Exportformate von Dia geladen werden können und dass ein Export meist mit einem gewissen Informationsverlust einhergeht.


8.2.1. Native Dia Diagrammdateien

Das einzige Format, das garantiert verlustfrei ist, ist Dia XML. Glücklicherweise ist es unwahrscheinlich, dass Sie versentlich ein Diagramm in ein verlustbehaftetes Format exportieren, da Datei->Speichern immer Dateien im Dia XML Format erzeugt.

Dateien im Dia XML format können mit dem Gzip-Algorithmus komprimiert werden, um Speicherplatz zu sparen. Das ist hilfreich, da die XML-Dateien sonst sehr schnell sehr gross werden. Kompression von komprimierten Dia XML-Dateien in Archivdateien wird die Dateigröße nicht signifikant verringern.


8.2.2. Importformate

Dia ist in der Lage, die folgenden Dateiformate zu importieren:

  • Skalierbare Vektorgrafik (SVG)

  • Drawing Interchange Format (.dxf)

  • XFig Dateiformat (.fig)

  • Verschiedene Rastergrafikformate (.bmp, .gif, .jpg, .png, .pnm, .ra, .tif)


8.2.3. Exportieren: Unterstützung anderer Formate

Dia unterstützt den Export in zahlreichen Dateiformaten, wie beispielsweise:

  • Computer Graphics Metadatei (.cgm)

  • Native Dia Diagrammdateien (.dia)

  • Dia Form-Datei (.shape)

  • Drawing Interchange Format (.dxf)

  • HP Graphics Language Exportfilter (.plt, .hpgl)

  • Gekapseltes PostScript (.eps, .epsi)

  • Portable Network Graphics (.png)

  • Skalierbare Vektorgrafik (SVG)

  • komprimierte Skalierbare Vektorgrafik (.svgz)

  • TeX Metapost Makros (.mp)

  • TeX PSTrick Makros (.tex)

  • WordPerfect Grafik (.wpg)

  • XFig Dateiformat (.fig)

  • XSL Transformation (.code)

Dia kann die Dateien in den meisten dieser Formate nicht laden. Diese Formate sind nützlich, um Diagramme in anderen Applikationen einzubinden oder um sie an Nutzer von Betriebssystemen, die Dia nicht unterstützt.

Um eine solche Datei zu erzeugen, wählen Sie Datei->Exportieren... aus dem Menü. Im Speichern-Dialog wählen Sie einen Namen und das gewünschte Format. Die entsprechende Dateiendung wird automatisch angehängt.


Kapitel 13. Autoren

Dia wurde ursprünglich von Alexander Larsson entwickelt und wird momentan von Hans Breuer und Anderen gepflegt. Um mehr über Dia, zu erfahren, besuchen Sie dia-installer.de oder live.gnome.org/Dia. Bitte tragen Sie sämtliche Kommentare, Vorschläge und Fehlerberichtet in der GNOME Fehlerdatenbank ein. (Eine Anleitung dazu finden Sie online.) Alternativ können Sie sich an die Dia Mailingliste wenden.

Dieses Handbuch wurde von Henry House (<hajhouse@houseag.com>) , Judith Samson (<judith@samsonsource.com>), Kevin Breit (<battery841@mypad.com>) und Alan Horkan (<horkana@tcd.ie> geschrieben. Es wurde im August 2007 von Mark Dexter erheblich erweitert und überarbeitet (<dextercowley@gmail.com>. Bitte senden Sie alle Kommentare und Anregungen zu diesem Handbuch an das GNOME Documentation Project. Dazu könnnen Sie eine Email an <docs@gnome.org> senden oder Kommentare online über die GNOME Dokumentation Status Tabelle absetzen.

Ins Deutsche übersetzt von Steffen Macke (<sdteffen@gmail.com>).


Kapitel 14. Lizenz

Inhaltsverzeichnis

14.1. Lizenz


14.1. Lizenz

Dia unterliegt den Bedingungen der GPL. Aus rechtlichen Gründen ist der folgende Text in englischer Sprache verfasst.

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

A copy of the GNU General Public License is included as an appendix to the GNOME Users Guide. You may also obtain a copy of the GNU General Public License from the Free Software Foundation by visiting their Web site or by writing to

Free Software Foundation, Inc. 59 Temple Place - Suite 330 Boston, MA 02111-1307 USA


Anhang A. GNU Free Documentation License

Copyright (C) 2000, 2001, 2002 Free Software Foundation, Inc. 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA. Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document "free" in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document must themselves be free in the same sense. It complements the GNU General Public License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose is instruction or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated herein. The "Document", below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as "you". You accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A "Modified Version" of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications and/or translated into another language.

A "Secondary Section" is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or authors of the Document to the Document's overall subject (or to related matters) and contains nothing that could fall directly within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A "Transparent" copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public, that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A copy that is not "Transparent" is called "Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced by some word processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires to appear in the title page. For works in formats which do not have any title page as such, "Title Page" means the text near the most prominent appearance of the work's title, preceding the beginning of the body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as "Acknowledgements", "Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when you modify the Document means that it remains a section "Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may have is void and has no effect on the meaning of this License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices, and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute. However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document's license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a chance to provide you with an updated version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

  1. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version gives permission.
  2. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this requirement.
  3. State on the Title page the name of the publisher of the Modified Version, as the publisher.
  4. Preserve all the copyright notices of the Document.
  5. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.
  6. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this License, in the form shown in the Addendum below.
  7. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document's license notice.
  8. Include an unaltered copy of this License.
  9. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no section Entitled "History" in the Document, create one stating the title, year, authors, and publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.
  10. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network locations given in the Document for previous versions it was based on. These may be placed in the "History" section. You may omit a network location for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.
  11. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title of the section, and preserve in the section all the substance and tone of each of the contributor acknowledgements and/or dedications given therein.
  12. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered part of the section titles.
  13. Delete any section Entitled "Endorsements". Such a section may not be included in the Modified Version.
  14. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title with any Invariant Section.
  15. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified Version's license notice. These titles must be distinct from any other section titles.

You may add a section Entitled "Endorsements", provided it contains nothing but endorsements of your Modified Version by various parties--for example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions, provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original documents, forming one section Entitled "History"; likewise combine any sections Entitled "Acknowledgements", and any sections Entitled "Dedications". You must delete all sections Entitled "Endorsements".

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution medium, is called an "aggregate" if the copyright resulting from the compilation is not used to limit the legal rights of the compilation's users beyond what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate, the Document's Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document, and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License "or any later version" applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices just after the title page:

Copyright (C) YEAR YOUR NAME.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section entitled "GNU Free Documentation License".

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the "with...Texts." line with this:

with the Invariant Sections being LIST THEIR TITLES, with the Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software license, such as the GNU General Public License, to permit their use in free software.